Flameshot does not work anymore after some time

I use Zorin OS 16.3 64bit and Flameshot for making screenshots and am a relatively new user of Zorin OS. Directly after installing Flameshot is worked like a charm and I like the application. However, now the application does not start anymore and I don't know why.

Anyone with the same issue?

Flameshot still works normally after approximately the same time under Linux Mint.

Hello, is it a flatpak or .deb?

See if this guide helps (zorin is a fork of Ubuntu):

https://randomblog.hu/setting-flameshot-as-the-default-screenshot-app-in-ubuntu/

Also see official troubleshooting guide:

Thanks for your quick reply. This is really great to get help so promptly here in the forum!

I have installed now the flatpak version of Flameshot and uninstalled the apt version and will monitor if I see the same behavior.

I have seen this behavior for the version from the source "ubuntu-focal-universe", so I guess this is the .deb version or could also be called the apt version (installed with the apt package manager)?!

correct.

Try start it up via terminal.

flame-shot

I think the command is. Or

flameshot

I've had this problem as well with Flameshot, for some reason it just refuses to launch normally. I need to launch it with flameshot gui to have it work normally. I haven't looked much into it since it's an "easy fix", so unfortunately can't say what's going on with it...

1 Like

The command is flameshot for the other one the terminal tells me the command does not exist.

I have tried to start it up with the terminal command, but it still does not work.

flameshot gui also works for me!

It is a pity though that you cannot start it normally from the start menu.
I have also installed the flatpak version now and will see if it behaves the same way.

Maybe check the launch command in the .desktop file for Flameshot and see if the launch command needs to be adjusted.

2 Likes

where do I find this file exactly?

For the apt version, it should be in /usr/share/applications or in ~/.local/share/applications

1 Like

Great! So, turns out, that running flameshot without any subcommands will simply run it in the background and show this icon for configuring it:

sc1

Depending on the layout you've chosen, this may not actually appear (this is due to the desktop environment not specifically related to ZorinOS). You need to specify another subcommand such gui or screen in order to instruct flameshot to do something.

What I'd recommend is modify the default print screen keybinding to launch flameshot instead of the default Gnome Screenshot. In Settings -> Keyboard Shortcuts, first remove the default keybinding by searching for "print", and then add yours specifying the flameshot command. To learn more about which commands you can specify just read the manual by running man flameshot.

EDIT:

To follow Aravisian's advice, if you don't want to mess with keybindings, follow these steps:

  1. Open a terminal and use a text editor such as nano to edit the flameshot.desktop file:

    sudo nano /usr/share/applications/flameshot.desktop
    
  2. Search for a line named "Exec" and modify the it to run the command that you want, for example:

    sc1

    Save the changes with Ctrl + O, and Ctrl + X to exit the text editor. If you have flameshot already running, you may need to close it in order to make sure these changes take effect. But this should now run flameshot directly from the start menu.

2 Likes

thanks so much for your detailed reply and explanations. I hope this will also help other users to more easily work with Flameshot!

2 Likes

It already helped me! I've had it installed for months but was too lazy to look into what was wrong with it, so this gave me the perfect excuse to do it :smiley:

2 Likes

I will have to give flameshot a try. My current favourites are Spectacle (from KDE Plasma) and Shutter, but not sure if the latter still works.

hello there
I wanted to follow up on this topic again. In principle zenzen's solution works if you start flameshot from the start menu after adapting the flameshot.desktop file or directly launching the application via the flameshot gui command from the terminal.

However, I still found some funny behavior. When flameshot works correctly (after fresh install), the application icon was displayed in the lower right corner in the task bar. This is not the case after the fix. Additionally, the copy to clipboard function does not work on my system. It does not copy anything and the clipboard still carries the previous record (for example some text that has been copied previously).

I've been having some issues with Spectacle of a similar nature when I want to take a new rectangular screenshot it has sometimes picked up its own capture result in the delayed screenshot, but this is on KDE neon which I'm using virt-manager to run Zorin 17 so I can take screenshots for the Unofficial manual I am currently working on.

Yeah, that's weird I'm not sure what's up with that... I even tried on a fresh installation and it seemed to work at first but upon restart the shortcut icon at the taskbar didn't appear anymore, although I didn't have issues with the clipboard.


Wasn't there an option to create reminders on Discourse?

This may be necessary to report the bug to the Flameshot developers themselves.