Flameshot with flatpak Qt session error

Hey everyone ... I'm facing an error attempting to run flameshot via flatpak

❯ flatpak run org.flameshot.Flameshot
Gtk-Message: 14:24:42.363: Failed to load module "canberra-gtk-module"
Gtk-Message: 14:24:42.364: Failed to load module "canberra-gtk-module"
Qt: Session management error: Could not open network socket

any ideas?

The two first error you can ignore. The third one install flatseal and setup flameshot permissions.

@Storm thank you so much for the help. Do you know what are the permissions I need to allow?

Nope, I try to avoid Flat and snap as much as possible - so I have not a clue other than it has to do with something network.

all right, anyway, if I find a solution I'll post it here so others can use it as well

1 Like

Look under 'Installed' through Software Center - if you click flameshot, do you have a 'Permissions' button?

Chirp has some permissions settings through the Software Center that can be edited; if they're there. Some apps I have installed have the permissions button, some don't.

Also - you could uninstall the flatpak version and get it through apt - sudo apt install flameshot. Should be in the list.. I'm using Ubuntu but not Zorin at the moment to confirm; I'll switch and take a look..

(edit) Yep! It's available on my side; would suggest using the apt version though. I do have some snaps and flatpaks myself but, though the work - they can be difficult at times..

Yes, it's available here as well, if I can't solve it, I'll use the apt version.

(edit) Just to add a little more info. One thing I found out is when I remove the folder "/home/rafael/.var/app/org.flameshot.Flameshot" then it properly starts, however, if I restart my computer, then the same error happens.

1 Like

Have you tried using terminal and running flameshot gui? You can edit the launcher in the 'start' Menu to reflect using the 'gui' part if that works.

Also was reading that someone got it running correctly by installing the snap version - last in the list for me when searching 'flameshot' in Software; if the above doesn't do anything.

Thank you so much guys for the help, I ended up using the apt version, snap installation also doesn't work, due to this error Allow Global auto connect forkde-frameworks-5-91-qt-5-15-3-core20 - #5 by adetter - store-requests - snapcraft.io

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.