Flatpak returned "Remote "zorinos" not found" after reinstalling flatpak

Flatpak ran into some problems and I tried to reinstall it, after this there's only one repository called "system" but no "zorinos". I tried "flatpak update" and this returned.

 ~  flatpak update                                                                                             ok  09:25:09 
无法更新 runtime/org.gtk.Gtk3theme.ZorinBlue-Dark/x86_64/3.22:Remote "zorinos" not found
无法更新 runtime/org.gtk.Gtk3theme.ZorinBlue-Light/x86_64/3.22:Remote "zorinos" not found
无法更新 runtime/org.gtk.Gtk3theme.ZorinGreen-Dark/x86_64/3.22:Remote "zorinos" not found
无法更新 runtime/org.gtk.Gtk3theme.ZorinGreen-Light/x86_64/3.22:Remote "zorinos" not found
无法更新 runtime/org.gtk.Gtk3theme.ZorinGrey-Dark/x86_64/3.22:Remote "zorinos" not found
无法更新 runtime/org.gtk.Gtk3theme.ZorinGrey-Light/x86_64/3.22:Remote "zorinos" not found
无法更新 runtime/org.gtk.Gtk3theme.ZorinOrange-Dark/x86_64/3.22:Remote "zorinos" not found
无法更新 runtime/org.gtk.Gtk3theme.ZorinOrange-Light/x86_64/3.22:Remote "zorinos" not found
无法更新 runtime/org.gtk.Gtk3theme.ZorinPurple-Dark/x86_64/3.22:Remote "zorinos" not found
无法更新 runtime/org.gtk.Gtk3theme.ZorinPurple-Light/x86_64/3.22:Remote "zorinos" not found
无法更新 runtime/org.gtk.Gtk3theme.ZorinRed-Dark/x86_64/3.22:Remote "zorinos" not found
无法更新 runtime/org.gtk.Gtk3theme.ZorinRed-Light/x86_64/3.22:Remote "zorinos" not found

How can I get the repo "zorinos" back?

Would you check the software updater settings and ensure that the server is pointing to main, not to a local server.

Thanks very much, it's pointing to main but it still returned the same error. After I reinstalled flatpak, there's no remote and I added the "flathub" one, but I don't know the url of "zorinos" remote so I can't add it back.

I'm sorry i can't be of more help. I removed flatpak and snap from my system.

Though i don't understand why you no longer have it, since removing package managers doesn't change the sources list.

Where did you get the iso? Did the checksum match what's listed on the official website?

There were some problems with the remote gpg and use apt remove can't solve it , so I tried sudo apt purge flatpak and lost the remotes.

I tried to boot a CD in a virtual machine and run flatpak remotes --show-details. I found the url is https://flatpak.zorinos.com/repo/

So I tried flatpak remote-add --no-gpg-verify zorinos https://flatpak.zorinos.com/repo/

Then I checked update and it worked properly

Solved, thanks very much.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.