Flicker effects after booting Zorin OS 16 lite

Installing OS works fine. After reboot and after enter login credentials to desktop is shown and there is a flicker trough the hole screen (only a few seconds). After that the desktop image will be loaded correctly.
Then the taskbar flickers also. After that everthing seems ok.
Whats the problem, my installation of zorin os 16 pro (earlier) worked fine.
See the screenshot for systeminformation:

Please post the output of

sudo lshw -c video

Or if you prefer inxi

sudo apt install inxi

inxi -G

Sorry, could not work with these problems. Have therefore installed Zorin pro. Since everything runs fine.
Does the info data still help?
In any case here:

Beschreibung: VGA compatible controller
Produkt: HD Graphics 530
Hersteller: Intel Corporation
Physische ID: 2
Bus-Informationen: pci@0000:00:02.0
Version: 06
Breite: 64 bits
Takt: 33MHz
Fähigkeiten: pciexpress msi pm vga_controller bus_master cap_list rom
Konfiguration: driver=i915 latency=0
Ressourcen: irq:123 memory:e0000000-e0ffffff memory:d0000000-dfffffff ioport:3000(Größe=64) memory:c0000-dffff

1 Like

Yes, actually, it does. Though it does not leaad me to a fix, it may offer a workaround.

First... some history.
Xubuntu 20.04 comes with XFCE 4.14
Zorin OS 16 Lite is based on Xubuntu 20.04 but offers XFCE 4.16

I, too, have noticed that the xfce4-panel in 4.16 does some... odd... things.
For example, after opening a Menu or popover from the panel, the red outline that normally is present during Panel Edition appears. And it won't go away.
I have noticed (and reported) that the Tasklist buttons (Window Buttons) will sometimes vanish under heavy use. You must refresh in order to get them to appear again.
It appears that 4.16, still in active development, has some standing bugs.

Workaround: Running xfwm4 with vblank_mode set to off

xfwm4 --replace --vblank=off

I understand that you are now on a different desktop; but it is worth putting this out there for other Lite Users.

1 Like

Great, thanks for reply

Hi Aravisian:
I reinstalled Zorin lite on a second partition.
Then i tried the workraound. Seems to work but in the terminal the session stays running.
How can i terminate this process without lost the settings?

1 Like

You can set this to always operate with:

xfconf-query -c xfwm4 -p /general/vblank_mode -t string -s "off" --create

This way, you do not need to run it every time. :wink:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.