Flicker in GNOME desktop, especially at high res / refresh rate

Hello all, as the title says, I am getting some flicker issues with the display of general apps on my GNOME desktop. I have recorded a video example, where I switch between different images very quickly. Occasionally you can see the previous image, or part of the previous image, returning for a brief moment after I have already switched to the next image. At 165Hz the issue is much more noticeable, but the video is only at 60FPS so only the worst cases can be seen.

Video download link (www.file.io)

The issue is also very noticeable when entering text or using the Super key to display all windows/switch workspaces (jittery animation), but not when watching videos, gaming, or moving windows. Pushing the Super key a few times makes the desktop 'smooth out' and the issue goes away for a few moments.

The issue does not occur when I boot from live USB so it must be something that I have tinkered with that has caused the problem...

It feels as though the more I type, the worse the issue gets. I really like the experience of the GNOME desktop on Zorin so I am very set on trying to solve this issue rather than giving up!

Specs:
Inbuilt display on 2024 Lenovo Legion Y9000X (Chinese market version of 7i, same hardware)
NVIDIA GeForce RTX 4060 Laptop GPU (8GB VRAM)
3200*2000 @ 165Hz
X11
GNOME Shell 43.9
NVIDIA-SMI 545.29.06

The issue was not solved by:

  • Updating Nvidia driver
  • Restarting GNOME (alt-f2 'r')
  • Switching to 'performance mode' in Nvidia PRIME settings
  • Switching to 'prefer maximum performance' in Nvidia PowerMizer settings
  • Switching to 60Hz
  • Switching to the Performance preset in Power settings
  • Reinstalling GNOME Shell
  • Backing up xorg.conf.d to auto-generate a fresh one

This issue seems to have been solved by switching the power mode setting BACK to 'balanced' and switching the Nvidia PRIME profile to 'on-demand'.

1 Like