Folder Deletion (assigned to Root User)


I tried to install HP Linux drivers for my m479fdw yesterday. After the terminal script went through a few processes, it requested root user login. But, I had no idea how to login, as my normal password set during OS16 installation didn't work.

I quit the driver installation and now there's a folder I want to delete, but, it is assigned to root user. How do I get rid of it, or, even install the drivers without root access?


Thanks all!

You can install this small app ebnabling opening the folder as root/administrator to do whatever you want to do (just be careful when you are in system folder though).

sudo apt install nautilus-admin



Can you try:

This will change the ownership:
sudo chown -R "$USER:" /path/to/the/directory

Also, I'd recommend managing root folders with the terminal. It's much easier, and it can help you understand how to use Linux more efficiently.

1 Like

Hi Kedric.
It is another option.
But my method gives a permanent power to be a administrator/root when necessary.

You mean Home folders?


8 posts were split to a new topic: Terminal commands vs GUI

This concerns me an I think should also be addressed first.
The normal log in password and Root access password should be the same.

1 Like

I tried it. But, system said my password was incorrect. The installation ended too after 2 more times. I then retried installation all over again a few time and got the same response. I gave up midway in the final attempt.

1 Like

IF this was me... I would reinstall Zorin OS. Please state if doing so would be overly-troublesome... But if there is any discrepancy between your root and login password, it is better to get a fresh start.

1 Like

It'll be annoying. But not extremely. I'll have to re-setup many email and online account, WeChat desktop application, on Wine and maybe a few other random applications from the Software Center,and minor GNOME tweaks.

I should probably download another ISO from the link just in case there's any update since a few days ago, then burn another one to my thumbdrive.

1 Like

I just tried it. My normal password didn't work. :frowning:

1 Like

You can save your home ~/.config folder to preserve many of these settings, then just transfer that directory to the new installation.
If you use Firefox and sign into FireFox Sync, this can save your Firefox data.

1 Like

Can you show me how? I don't see that folder in the GUI.

I should also re-download the iso just in case there's any recent updates sicne my installaion yesterday.


In your file manager hit the keybaord shortcut ctrl+h to reveal system files (Or Hidden files.)

You should see .cache, .config...

1 Like

I see the hidden folders now. I'll upload the folder to my NAS. I ran outta thumbdrives or external HDD. LOL.

1 Like

The way I do this, is I compress them as .tar.gz
As well as

That way they take up less space but are also "in stasis" so to speak, ensuring less chance of corruption by transferring them around.
Then when the new installation is done, I move the compressed files in and uncompress them or replace and uncompress.
It sounds involved but is done within three sandwich bites. You hardly notice.

1 Like

I don't know man, but when I compress stuff they don't get much smaller.

I thought of zipping them too. I'l compress them. Seems like my root is already full too. My download of the iso failed.


Did you assign a small root partition at installation?

I let the installation do it automatically. I'm not familiar with Linux so I didn't do any manual tinkering but allow a 60GB share of the 256GB SSD with my Win10+Recovery parititons inhabiting the rest. This is the result:

It concerns me that Root would have filled. 60gigs should be enough.