For a long time I've been having problems with drag & dropping URL's and large image files

1.) This worked in Windows OS fine, but wont work in Zorin, in neither Nemo or Nautilus.
I can drag & drop this URL to a folder on my USB drive:
https://www.google.com/search?q=test

I can drag & drop this URL to a folder on my USB drive:
https://www.youtube.com/watch?v=wtMWrrOSbfo

BUT I cannot drag and drop this to a USB folder:
https://www.youtube.com/watch?v=YpOvA3Khd9w


2.) I cant drag a large image file, like more than 1MB, from my browser into a folder, even a non USB folder. In either Nemo or Nautilus.
Prime example of an image I cant do it with:
https://picjumbo.com/wp-content/uploads/beautiful-nature-scenery-free-photo.jpg

Are you using Z17 Wayland (default) or X screen session on login?
If using default, maybe try hitting the cogwheel icon on login screen and see if any better using X.

1 Like

What FileSystem is your USB stick formatted to?
Have you checked permissions for that folder?

1 Like

@Aravisian , 1.) 124GB NTFS partition.

2.) I checked folder permissions using ls -l

this is what i get:
image

3.) After more thought about this problem, it appears the " | " symbol, which is called a "pipe" or "vertical bar" is likely the problem.

Drag/dropping wont work for this link either, to a USB:
https://www.youtube.com/watch?v=FdJriCs_Y8k

BUT, what does work and what I can do, is drag drop it to a NON USB location, then copy/paste that to the USB, oddly. But still, I want to fix this problem, as this takes up a lot more of my time.
image

@zabadabadoo , I am by default using "Non wayland", but I also tried using wayland as well. Neither will drag and drop this youtube link to the USB folder.

You can write, due to Zorin OS including the ntfs-3g package. The pipe should not affect this (I could be wrong, we can revisit that), but what about the file size?

You are asking what the file size is for the url link? it's 182 bytes.

Can you test this using a USB stick formatted to exFAT instead of NTFS?