Fractional Scaling not working, just zooms in to the top left of the screen

Whenever I try fractional scaling, it always zooms in way too hard to the top left of the screen.

Pic of what happens:

My laptop info:

This is on a fresh install.

1 Like

There are a large number of bug reports filed for Fractional Scaling in Ubuntu and Ubuntu derivatives.

Sadly, this is an issue that is best addressed by the original developers.

2 Likes

Yes, I too have had issues with fractional scaling, which is why I don't use it.

Instead, I enlarge the size of all text in my OS, I enlarge the panel size, the ICON sizes. If an APP like Steam has text too tiny, and believe me it does, I use the ZOOM function from the accessibility panel, SUPER ALT 8, turns on the zoom, CTRL ALT 8 turn off the zoom.

Setting zoom amount, can be done in accessibility.

Also, internet browsers often come with their own font size adjustments. And if none of those browsers are to your approval, there is always Vivaldi I suppose, which is known to be highly customisable.

2 Likes

Or use a telescope to zoom in :joy:, turn it away to zoom out :stuck_out_tongue_winking_eye:

GOOD NEWS! It turns out there's a workaround and I managed to (sort of) get it working. This comment in the bug thread tells you how to activate kernel mode setting, which somehow fixes fractional scaling for Nvidia GPUs. There was one problem where some application fonts are way too small, but I'm sure that can be fixed with some tweaks.

Bad news: I honestly didn't like it... Everything felt way too big at 125%, especially title bars that take too much screen space. After making sure it worked, I just turned it back off :upside_down_face:

Chrome also comes with a built in zoom function as well, and I use that all the time, cause I am viewing the browser on a 4K 55" TV, and everything like text is super small, so I got to zoom in on everything to properly see it.