Freeze after suspend long enough

I had the same problem. I found a work-around in the settings, wich solved it for me. I think it could be a conflict with overlapping settings between "Settings - Power - Screen" and "Settings - Privacy - Screen".

I changed one or two settings in "Settings - Privacy - Screen", and the problemm was solved for me. However I did not write down what I changed. I am trying to remember, but can't be sure.

I think I disabled "Automatic Screen Lock", but it also might have been "Blank Screen Delay" I disabled by setting it to "Never". As I don't fully remember, you could try to make sure all your settings in "Settings - Privacy - Screen" is the same as my settings, as I did only change what was needed to solve the problem in "Settings - Privacy - Screen". Here is a image:

For comparison, here is a image of my settings in "Settings - Power - Screen" (if I am correct you don't need to change any settings here):

Hopefully changing/disabling settings in "Settings - Power - Screen" also work for you. As I said above think it could be a conflict with overlapping settings between "Settings - Power - Screen" and "Settings - Privacy - Screen". I have a very strong gut feeling that is the explanation for why it fixed the problem on my computer.

(Edit: Uploaded the first image again, it was without color, now it has color.)

Edit 2: By the way, if somone that have not changed the settings in a new install in "Settings - Privacy - Screen" could share a image of their settings, then I can compare with my settings, and then we can know for sure what setting I disabled to solve the problem.