Freeze at login Zorin OS 16.1 Core

Hi- Been running Zorin OS 16 core for about 6 months on my Lenovo Thinkpad P50 with few issues. After a shutdown a few days ago, I'm unable to login. I get a frozen login screen. After clicking on my user name, the lockscreen appears but will not accept password entry. Mouse arrow is frozen, keyboard as well. Not able to switch to a terminal window.

I'm running kernel 5.13.039 and also have 5.13.037 installed as well.

Computer is a dual boot. Windows is installed on a separate NVME drive, and it boots up fine. Computer has hybrid Intel/Nvidia graphics.

I've been unable to run fdsk from grub console.

Home files are backed up via BackInTime, and there is a TimeShift back up snapshot series availble as well. They are on a separate intenal SATA SSD.

Booting from a USB stick (MX LInux) shows all drives and partitions. I attempted to run a timeshift restore, but although it started, it was taking forever to do the initial file check.

After leaving the login screen up for a while, I get a lot of terminal output with failed to write entry for systemd-journal being most prevalent

Any suggestions for a fix would be appreciated. Thanks.

On the login screen try to run CTRL+ALT+F5

This should open a terminal window. Login there.

Once in a terminal run: dmesg
this should tell you if there was a hardware error.

You will most probably have to visit a proper technical forum to request help as the causes and solutions can vary a lot.
I would check the firmware version of your SSD and if you can, update it.

Thanks, but I'm not able to open a terminal window. As soon as I run CTRL+ALT+F5, my screen freezes and I get no keyboard entry or mouse input.

I can't access the SSD to check firmware, but I see that ADATA has an SSD toolbox, so I'll see if that will work from the windows side of the machine.

Are you able to boot into Recovery from the grub menu?

Yes, let's not update the firmware now, I think it will clear the data in this process.
I could be wrong.

There were issues in the past with Ubuntu and SSD using the Trim function. Could be that this messed things up, but also it could be something completely different.

They suggest a full backup before update, so let's play it safe for now. I do have both Timeshift and home directories backed up if I need to reinstall.

Sorry I deleted the response by mistake. Yes I can boot into recovery mode from either Kernel

Do you have a Nvidia or do you have an AMD graphics card?

From Recovery, are you able to boot into the earlier kernel and test if the current issue resolves?
If that does not resolve, in the Recovery Menu, enable networking, then drop to prompt.
Hit enter
Then run

sudo apt install --reinstall zorin-os-desktop

Follow any prompts to reconfigure GDM.
Proceed to normal boot and test.

It may be hardware and you may need to run fsck, but let's try the easy things, first.

Thanks
Computer is a dual boot. Windows is installed on a separate NVME drive, and it boots up fine. Computer has hybrid Intel/Nvidia graphics.

I can give that a try.
Results:
Iniial console output:

/lib/recovery-mode/recovery-menu: line 80 /etc/default/rcS: no such file or directory

Entering sudo apt install --reinstall zorin-os-desktopseems to have no effect. Console shows new line with blinking cursor.
After a while (10 min) , a fast scrolling set of error messages appeared in the console.Took a hard power off to shutdown.

I burned a fresh Zorin OS16.1 to a usb stick, was able to boot up (but in safe graphics mode). I've also used a usb stick of MX, boots ok, but as soon as I touch the drive my Zorin install is on, the file manager either freezes, or shows me an empty home directory, or unmounts the partition.

Did you get this from running fsck?

No, from choosing networking in the recovery screen. As soon as I select the networking option and hit yes, that line appears in the console

In this case... it does indeed look like Root is Corrupted.
Have you yet run a S.M.A.R.T. test on the drive to test for bad blocks or sectors?

I ran a smart test, but I don't' think it was successful. I used the mfg's software in Windows, the test ran for a while and populated a screen, but I was not able to scroll through the screen to get any meaningful data. The quick test was ok, but I doubt it's accurate.

I'm thinking that the smart test that is available in the gnome disks tool might give me something useful. I could try booting from the Zorin USB stick and running it. Let me know please if you think it's useful.
Dut to the sudden nature of this problem, my gut says that this is a hardware issue, and I'm going to open up the computer to get the serial number of the device and photograph it. I'll also inspect the connectors for dirt, and replace it and check it one more time before putting in a warranty claim.

I would definitely try that. Please ensure that the disk you are testing is unmounted.

Well, not my lucky day. Smart Data & self tests are greyed out for that drive in the disks menu. The SMART tests are available on other drives on the computer. I'll open up the pc and see where that gets me. Thanks, I'll be in touch.

So getting back on track here. Turns out the problem was an ssd drive went bad. Luckily under warranty, and a replacement has arrived. I have a question about the restore:

I have both a timeshift bu for system files, and a back in time bu for the /home files.
The original system was Zorin16 Core.
What is the best sequence for restore? Fresh install from USB Stick, then timeshift then BackInTime?
It is a dual boot system, and it looks like the bootloader is still alive. I can boot windows fine.

Thanks.

I would agree with this, simply as i makes the most sense to get Root sorted out first.

Well, the saga continues. The replacement SSD arrived from ADATA, and was DOA. Have RMA'd it back. Purchased a new SSD from Samsung, installed and worked fine. After installing a fresh Zorin OS 16 Core, and then TimeShift, and then a restore from a snapshot, the systen fails to reboot. If I open a terminal window, I can see (briefly) in very tiny type (yes, it's 4k display), a few error messages:

failed to mount /mnt/BackinTime
failed to mount /mnt/Timeshift
failed to start remount boot and kernel
failed to activate swapfile systems

The terminal pauses for a while, and then continues to throw up messages before locking up.

My guess it that the mount points for these volumes has changed from the locations in the original snapshot, and that's why it's failing. Rather than pursue a fix, I think it's faster for me to reintstall the OS (this time I'll go with the Pro version to match my desktop, then restore my BackInTime home folder, then add whatever else I need to get back up and running.

I guess that Timeshift, which I've used before to do rollbacks on my Manjaro version sucessfully doesn't work or isn't meant to be used when trying to roll back after a complete reinstall.

Hopefully the home folder restore will go well. I don't really have anything ultra critical to restore, since I had the opportunity to move critical files to my desktop, and other doc's were synced to google drive. It does make me wonder if there is a better way going forward. I guess this is a matter of time/benefit.

Have you checked your fstab file?

I would have, and I'm pretty sure the issue was the mount points were different than the original install. I went ahead with the full install, followed up with my backintime restore, and added all my extra apps. Seems good to go, will take a closer look tomorrow. I'm wondering if it would make sense to do a clone Zilla disk image once things settle down to use as a backup base for any future reinstall. Might be a useful starting point to install from, followed by timeshift and backintime restores.