Fresh Install Dell Latitude 9430 - Unusable

Need help. I have a Dell Latitude 9430 (it's a 2 in 1 with touchscreen) and did a full install of Zorin but it is unusable. The lag of even just moving the mouse pointer is garbage as the input lag of showing and screen tearing is just too much. I've tried a couple fixes, changing from Wayland to Xorg, even decreasing screen resolution, but to no avail. Ran updater and even apt full update, no change.

Try with;

sudo apt install xserver-xorg-input-multitouch xserver-xorg-input-synaptics

Reboot and test in Xorg login.

Sadly can't even get the settings to popup any more at the login screen. Saw this with Core normal and Core (display driver safe) installs.

It's like it stops refreshing (I guess what's called repainting) the current window. I click on my name to log in and takes like literally a minute to show the options: Zorin Desktop or Xorg when I click the gear icon with my finger or with the touchpad.

Clicking on the "Start Button" to open the start menu takes the same amount of time UNLESS I move my mouse then the menu fully appears, whereas it's semi-transparent and then after about a minute fully appears if all I do is touch the start button and nothing else.

I tried the command you suggested but no real changes to this issue.

Did you see this lag on the LiveUSB of Zorin OS 17?

During the install I had the same issues.

Have you tested a LiveUSB of Zorin OS 16?
I suspect the lag will be missing on 16...

I'll try it with 16

Is there a repo with previous versions?

Yes, you can use SourceForge:

1 Like

Man sooooo much better. Thank you for the suggestion. Smooth install and no issues like 17 was giving me. I was really hoping to make this work.

1 Like

Zorin OS 16 is still supported and will be until 2025. Some users upgrade after the first point release (17.1) in order to ensure they do not experience any bugs that come with an Initial Release.

You are not the only user to note that Zorin OS 17 seems laggy on some machines. Zorin OS 17 is the first release to default to Wayland and is now on gnome 4+.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.