Fresh Install/Format Won't Boot / Might Be Driver Related

Hello,
First time using Zorin. Tried to install twice on freshly formatted computer, but getting the following message on boot after "sucsessful" install. Can any of you linux pros tell me what's wrong here?

You need to post what kind of processor and graphics card you have. Also what motherboard. All too often things like this are because the kernel is an older one and the PC might be relatively new. If the PC is about 1 year old or newer, the kernel in Zorin 16.3 might not recognize the hardware. Hopefully someone in the forum can help once you post more hardware specifics.

All of the above errors detail a Nvidia Graphics Card driver error.
As @C141ZorinOS pointed out, it would be very helpful to know which Nvidia Graphics Card you are using.
In the meantime, you may be able to resolve this issue and boot normally by blacklisting the Nvidia i2c driver.

You will need to access Grub Recovery Menu:

In the recovery menu, arrow key down to Root - Drop to Prompt
Tap enter
Create a new configuration file for blacklisting the driver in the modprobe directory. Use Echo to redirect the blacklist command into that new file (Doing it this way so you do not need to use touch then run nano then type in the line...):

echo "blacklist i2c_nvidia_gpu" > /etc/modprobe.d/blacklist_i2c-nvidia-gpu.conf

Update initramfs:

sudo update-initramfs -u

Once all is complete, exit the recovery menu and test a normal boot.

Ah I'm sorry for not including more information. I'd also like to add an additional issue, the boot loader and grub are both insanely laggy. Typing 90% of the time will double press a key or not press it at all. Making commands very difficult to execute.

My computer specs:
|Processor|AMD Ryzen 7 5800X 8-Core Processor 3.80 GHz|
|Installed RAM|32.0 GB|GPU NVIDIA GeForce GTX 1660

1 Like

This may be symptoms of the above - due to the processor repeatedly addressing the graphics issue. Let's try resolving the graphics issue, first.

If the other issue persists after that is resolved, we can start a new thread to address that issue.

1 Like

I'm back. o/
I spent quite a bit of time on this over the weekend but still no luck. I was able to disable the defective driver and run a much older version by doing the following:

sudo apt-get purge nvidia*
sudo apt autoremove
sudo add-apt-repository ppa:graphics-drivers
sudo apt-get update
sudo apt-get install nvidia-driver-440

However, it runs very poorly. I can't even use two monitors. I then tried the latest driver and that bricked the OS again. So again, I reverted back to 440.

GRUB still runs poorly. How do I know which driver will work best? Is there an easy way to switch between them all? This is very slow and painful.

hi Lex, are you using HDD or SSD on your machine?

Zorin is installed on a m.2 drive.
Windows is installed on an SSH..

Do you know if NVMe or eMMC?
eMMC has a bit of a reputation...

It's the samsung mzflv128hcgr-000mv which I believe to be NVMe.

I have gone ahead and done some web searching:

I am also seeing a lot of complaints of later drivers not working on the 1660. A lot of complaints about it behaving very slowly.

https://forums.linuxmint.com/viewtopic.php?t=395376&sid=c9ea36a0ee5b252289a9d534c17820a3&start=20

This last thread suggests that they solved the issue by installing an Ubuntu derivative of a later version.
This may mean a combination of higher kernel and 440 or 470 driver may help your system.

My laptop uses the 1660ti. It took some work, but i finally got the 525 driver to work for me. I'll check my configuration and give you the specific driver tomorrow.

Ultimately it was that i had to install the 515 driver then go to the 525.

This took several weeks of trial and error, and even that wasn't accepted at first. Many wipes of nvidia drivers prior to finding the combination for my system.

I believe it was the 515, non-proprietary to 525 server, but as i said, I'll get you my current config tomorrow.

This actually makes sense since the driver is of the same family (515/525/535/545). The second number seems to indicate version while the last number specifics the card family (chipset) it supports.

Again, by no means is this definitive, only my experience.

Correction: it was the 525 proprietary driver that finally worked. You will see the word proprietary behind the aptitude driver name in parentheses.

1 Like

Thank you Harvey.

Is there any easy way to switch between drivers? I managed to get zorin running on a very old driver. Stutters but works. Would love to update but afraid it will break again.

Forgive my late reply, as it has been a busy couple of days. It is trial and error. If you stay within the same family, you should be ok....i.e. 515 -> 525 -> 535. Once you reach one that works, not buggy, stick with it.

There is no point in getting the latest features for the latest cards. Even if your card can perform the operation, doesn't mean it should or that it won't work the card to no end. Get it to do what it is designed to, the features that are supposed to be a part of that card.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.