Fresh installtion Zorin 17.1 - some time audio work other time only noise

I've installed new OS Zorin 17.1, the only thing that doesen't work is audio.
Motherboard is MSI Tomahawk B360 with Generic [HD-Audio Generic], dispositivo 0: ALC892 Analog [ALC892 Analog].
On google I can't find a solution about this, audio one of 10 times works.

In the same PC on Windows 11 Partition the audio work fine.
Do you have any idea on this problem ?

I tried othe OS LinuxMX, Ubuntu 22.04, Fedora 39 same problem .........
I like Zorin I would like use it


Hi and welcome to the forum. Sound issues are not always easy to diagnose and fix.
When you hear noise, is that from all your sound outputs: speakers and headphones etc?
What output setting do you have in Zorin>Settings>Sound?
In sound settings, have you tried [speakers] "Test"
What output options are shown there? post a screenshot.

In terminal, type


Then check and unmute any outputs showing [MM] muted. Hit "M" to unmute.
Have a play with [Auto-Mute] and [Loopback Mode] settings to see any effect.

1 Like

Welcome to the Forum!

Are Your Speakers shown in the Gnome Audio Settings?

Did You tried PulseAudio Control? If not open the Terminal and type sudo apt install pavucontrol install it and then open it and set up Your Speakers.

With test audio no sound, configuration seams correct, sometime when I run sudo alsa force-reload and pulseaudio -kaudio come back to work, but is random


Try updating the audio drivers or installing proprietary drivers specific to your motherboard model for better compatibility with Zorin 17.1.

You are not alone.

Interestingly, a user complained of this issue on Windows OS, but said that it works "on Linux" but was not specific as to which distro.

However, he was referring to the headphones jack, not speakers.

This user claims that it is an MSI issue, involving the clocking of RAM:

I think the first link bears an answer that is most applicable.

Same problem here, I had to do an unortodox approach, my monitor does not have speakers, so I got a cheap HDMI Audio splitter box, connected the HDMI output from the motherboard to the splitter box, connected HDMI out from the box to the Monitor, and final step connected the speakers to the Audio out of the splitter box, and worked like a charm.

Spent days trying every trick on the web to solve it by software, but never worked, Ubuntu never recognized the card and "Sound System Settings" always saying "DUMMY OUTPUT", drove me nuts...

I've setting ram clock default but same problem

with bluethoot earphones work fine

From your Settings>Sound screenshot shows "Starship/Mattisse HD audio controller".
If that is correct for your motherboard, then websearch using "Starship/Mattisse HD audio controller ubuntu" reveals some results.
One being: [SOLVED] Audio only coming from HDMI - Linux Mint Forums
which suggests looking in your BIOS for audio output panel settings.
I am not suggesting this is an answer, as I dont know if that matches your hardware.