Full Screen makes fractional scaling go bonkers

Attaching a video as I'm not sure if words would completely describe the situation

Basically, if you full screen something (my case: vlc) while on fractional scaling (125%), the screen tries to go back to 100%, then tries to come back to 125% and so on. One thing I've noticed is that if I don't move the mouse, this doesn't seem to happen, so maybe rendering the mouse is what is causing this issue.

Now, I've read a few similar bugs on Ubuntu launchpad but none of them are solved (or even assigned). Most of them talk about some issue with mutter but I checked and realised that mutter is not even installed on Zorin so that cannot be the source of the bug. So I'm looking if someone has found a workaround or some patch.

PS: even after closing VLC, some gnome screens still don't look properly ( render at 100% and not at 125%) This however can be solved by restarting gnome ( alt+f2 and r)

As it is currently, Fractional Scaling is a Work in Progress. In my opinion, it is nowhere near ready for daily use.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.