Function button - maybe covered, couldn't find anything on it

Alright --

So, Asus laptop, Fn keys work except two. I was able to set the select-area screenshot button with Fn+F11, actually registers as Shift+Super+S.. But, when trying to set the Settings launcher (Fn+F12) shortcut, nothing comes out - like I didn't hit any buttons :thinking: The screenshot shortcut actually is for a screenshot shortcut though - like if I were in Windows, it would do the same as with Gnome screenshot and the crosshairs, drag and release to take the shot..

The other is a webcam / camera disable button - that one isn't listed in the keyboard shortcuts list, but same effect when trying to set a shortcut to something; no output. That one's not important though, opening Settings with one button is kinda cool though :grin:

Wasn't sure if there was a cheat-sheet of sorts for keyboard shortcuts that translates to Fn+Fxx actions - or not, probably not :joy: I've been trying to find something that shows what is being pressed when Fn+F12 is being used but, nothing so far has worked...

Just wondering! I'm sure it's probably some proprietary thing between Windows and the button(s). But, can't find much on it at the moment. Just weird screenshot works but the others don't.. Haven't tried any remapping - didn't want to mess up what does work now lol

(edit) I did find 0B3CBB35-E3C2- 000000ff 00000000 as the Fn+F12 output from acpi_listen.. not sure what I can do with that in terms of opening Settings though. I saw an Asus related post with that kind of string; but to control the backlight, I think.. Not sure if that helps anything or not.

This may be proprietary code in the Asus MB Programming. If so, you might have a much easier time of choosing a different keyboard shortcut.

You might follow the same steps here:

except checking for anything related to the camera / screenshot function or use of the fn keys you are trying to use.

If you do not find any that are being actively used - then you might try using dconf-editor to set the shortcut.
That the fn+F11 worked suggests that the function key is working properly and that it is the combination you are using that may be the trouble.

1 Like

Did not see either one - probably a proprietary thing then.. Dang it! :joy:

That's fine though, I can do another shortcut for sure though.

Didn't come up to use dconf-editor on any searches. Thanks though, that was more than what I was able to find. :+1:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.