Functions keys changing volume

My keyboard's function keys (F1, F2, etc.) perform media control actions by default on Zorin OS, unlike Windows where they work as standard function keys. I want them to behave as standard function keys without media controls.

What I've Tried:
I've checked the keyboard settings in system preferences, but couldn't find an option to switch the function keys back to their standard behavior. Additionally, I attempted to change the language settings, thinking it might affect keyboard behavior, but this didn't solve the problem.

How can I configure my function keys on Zorin OS to function as standard keys, not triggering media controls?

Interesting, I thought they all had a specific function, never heard that they only perform media control actions. Since Zorin OS Core installation I had no problem with function keys, the only difference I saw is that fn + F2 now sets flight mode while on Windows it was just disabling the Wi-Fi. Check Settings > Region & Language > Installed languages management > try another keyboard input system. Please restore the default one if others don't resolve the issue.

i mean that i cant use them as normal function keys they are only the specific function i just was giving that as an example sorry for the confusion

You mean pressed singularly or as key combos? On software and games they can be set singularly to do some specific actions but for system functions you have to hold fn and keys between F1 and F12 to trigger the corresponding action.

I am pressing the fn key. my keyboard is a 60% so i have to press fn for my numbers to become f1-f12

Are you using Zorin OS on a Mac Book or are you using an Apple Keyboard or Varmilo keyboard?

its just a regular 60% keyboardc called an adx mechanical keyboard. i attached a picutre of it

There is no way... I could ever use that.

I mean, I bumble all over my large scale keyboard all the time, whacking the F11 key by accident and so on... Are you a brain surgeon? :expressionless:

Have you tried tapping Fn + Esc to toggle the FN-Key functionality?

'Fn + Esc' doesn't work, and it's not my keyboard's fault. This problem is specific to Zorin OS; it doesn't happen on Windows or Arch Linux.

For some keyboards, that keyboard shortcut acts as a Toggle Switch to turn on or off the Function mode for the keyboard. It was worth checking.

Let's try double checking how the system is recognizing the keyboard. What is your terminal output of lsusb -v (Since that command produces a lot of output, let's try narrowing it down):

lsusb -v 2>/dev/null | egrep '(^Bus|Keyboard)' | grep -B1 Keyboard

It appears to think I have a apple keyboard. i have a mouse which does keyboard macros so one of those could be my mouse
lsusb -v 2>/dev/null | egrep '(^Bus|Keyboard)' | grep -B1 Keyboard:

Bus 001 Device 003: ID 05ac:024f Apple, Inc. ADXMK0620
bInterfaceProtocol 1 Keyboard
Bus 001 Device 002: ID 09da:3145 A4Tech Co., Ltd. USB Device #this one is my keyboard
bInterfaceProtocol 1 Keyboard

Ok, so... what is likely going on here is that the manufacturer is not flashing their hardware to be vendor-specific. Instead, they are trying to cut costs and labor and flashing all their hardware the same. This is... not the proper way to do things.
Hardware devices need to be able to accurately identify themselves.

Zorin OS includes the hid_apple driver; Indeed, many users install Zorin OS on Macbook and Macbook Pro devices.
This driver is in Debian, as well.

Hardware such as GPU, peripheral devices, wifi cards, motherboards all come with their own chips and own operating systems. You are familiar with the Motherboard Operating system: BIOS. The Human Interface Operating System is the one you interact with and choose; Windows, GnuLinux, Mac... This HID OS must communicate with the hardware OS; it cannot reprogram it. It can only communicate with it. This communication is done via programming that could be viewed as a Translator or Liaison. We call those Drivers.

What you can do aside from being a squeaky wheel to the manufacturer;

  • I do not recommend removing the hid_apple driver.

Try holding down the Fn + w keys for 5 full seconds. See if this shortcut exits Mac Mode.
If that does not work; the only remaining option is to create a new file to turn off the apple driver forcing the system to fall back to usb_hid

sudo -i


Navigate to /etc/modprobe.d/ and right click an open area in the file manager window and select to create a new document. Name that document hid_apple.conf. So the full path will be:


Copy the following and paste it into the new document:

options hid_apple fnmode=2

Save and exit the document. In the open terminal, type


Now run

sudo update-initramfs -u

Reboot and test keyboard functionality.

Reference; further reading:

1 Like

Thanks this fixed it!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.