FYI: kernel 5.15.0-41-generic broke multiple monitors

This is more of a community advisory: Running 16.1 Pro, I installed the latest update which included the 5.15.0-41-generic kernel. Upon reconnecting to my docking station I found that only one of my external monitors was working. I switched back to my most recent kernel (5.13.0-52) and re-installed DisplayLink, then rebooted and my monitors are back. As a side note, 5.15.0-41 also broke my VMWare Workstation vmnet and vmmon kernel module install. All in all, I would avoid 5.15.0-41.

Same problem with VMWare player here. Can't launch it, it tries to compile something and fails. It was originally installed with 5.13

1 Like

If you reboot, at the grub screen select the advanced options. You should be able to select 5.13.x and boot into that.
If you want to keep 5.15.0-41 I was able to use the workaround at the bottom of this post: The vmmon and vmnet vmware-workstation kernel modules fail to build on Rocky Linux 8.5. Anyone have an easy fix? - Unix & Linux Stack Exchange

1 Like

Thanks, I'll try the reboot into the previous kernel next.

Booting back to kernel 5.13 allowed me to update vmware player tools, and it worked again.
Rebooting back into kernel 5.15 allowed me to launch vmware, which came up with the requirement to install two modules, and this time they installed and vmware worked again.

1 Like

that's great! I'm waiting for the next patch before I try again :slight_smile:

1 Like

Then best version Zorin was when was first version 15.3 kernel?