Games aren't running well for some reason

In the last day or two games of mine that usually run perfectly fine aren't running properly anymore.
I didn't change hardware nor software, just all of a sudden now everything is stuttering and lagging
My GPU is a gt 1030 I never had any issues with it on zorin until just now
Was there a drivers update I missed or is it a hardware issue?

Possibly related to this:

OP mentions there was something related to Steam so maybe double check you're not behind on updates?

I wasn't playing steam games for the most part unfortunately I was playing cemu, then pcsx2 too make sure it wasn't just an emulator issue, then I tried the play on Linux version of project 64, and lastly I played half life 2 (the only steam game) and it was doing this.
I think something might be wrong with my graphics card but I can't tell. All of the previously mentioned worked flawlessly before with no hiccups but now of all sudden it's just not??

I just tried the render96 pc port of Mario 64 via lutris just too finally set it straight and yep.
It's not running properly.
I have no clue why this is happening.
Everything is running at 5 -10 fps

sudo apt install inxi
inxi -G

Lets see the driver and graphic config.

Unfortunately my baby bro broke my wifi antenna for my PC and I have too wait until Thursday when my new one comes in the mail...

I think was some regarding to steam, after a new release of steam, games works fine.

We've seen other packages installed as flatpaks that don't play well when they are even slightly outdated, and I'm guessing that's the case for you as well.

It would be worth asking @qwert what version is currently installed, at least while we wait for the new antenna, if nothing else to rule this possibility out.

PS: Maybe your brother also broke the graphics card... ? :smiling_imp:

alright got my antenna and followed your prompts and this is what I got
Device-1: NVIDIA GP108 [GeForce GT 1030] driver: nouveau v: kernel
Display: x11 server: X.Org 1.20.13 driver: nvidia
unloaded: fbdev,modesetting,nouveau,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: NV138 v: 4.3 Mesa 21.2.6

what does this mean??

It says that you are using the open source driver instead of the restricted ones. Try re-install the driver.

1 Like

omg that explains everything

how do I delete drivers?

Idk how the hell. but my OS put me on the nouveau driver automaticly for some reason. I just loaded the nvidia driver I normally use and now everything is running properly now.
no more stuttering or lagging or delay. thank you so much storm and zen zen

1 Like

I can't recall it as I'm using Fedora for a long time now. But I think it's something that is called "sources" something app nad then you go to "Additional drivers".

my baby bro never used my computer he just broke my antenna so i have no clue how this happened lmfao

It would not be wise to delete the neauveu driver. Blacklist it if you must, but it may be necessary if your driver fails. As long as the Nvidia driver loads, the generic won't be used. Use Nvidia Server Settings app to change Prime Select settings to always use the Nvidia card (not recommended for laptops when on battery).

Then the neauveu driver will only be accessed when the Nvidia driver fails or the card does.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.