Games not working after kernel update

Hi all. I've been using my Framework 16 laptop successfully with Zorin OS Pro 17.1.

I was able to successfully play Rimworld through Steam yesterday, but this morning I installed a kernel update, and now it doesn't work at all anymore. The first time I tried playing it'd load, but I'd get this crazy 0.5 FPS mouse movement and it just felt like running on a 100MHz computer or something; it was a struggle even to reboot without resorting to the power button. Even after closing the game, the navigating the desktop was extremely slow. After restarting I tried again to start the game and I just get a black screen with the custom cursor, but no degraded FPS, but no game either.

I'm not positive it was a kernel update; other packages were updated at the same time. But I'm most suspicious of the kernel update.

Anyone know what's going on? Should I try downgrading the kernel or what.


max@max-Framework16:~$ uname -a
Linux max-Framework16 6.5.0-28-generic #29~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Thu Apr  4 14:39:20 UTC 2 x86_64 x86_64 x86_64 GNU/Linux
max@max-Framework16:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Zorin
Description:	Zorin OS 17.1
Release:	17
Codename:	jammy
1 Like

Yes. Go back to the old kernel. Maybe that will fix it.


To do that. From your grub menu, select "Advanced Options for Zorin".
From there, select a kernel generic that is a version before the latest version downloaded.
Boot with that older kernel and test.

1 Like