Gdebi disappear and close when i click on install pacakge in its interface

gdebi was working very good, but today i tried to use it, it open , but when i click on install package it doesn't work and close and disappear immediately

I have had this happen to me before, as well.
Have you tried

sudo apt install --reinstall gdebi

no, it doesn't work

I wonder if policykit is the problem...
Can you try

sudo apt install --reinstall policykit-1-gnome

Reboot and test...

it doesn't work too.
i tried to run it in terminal, it's working , but i don't know why it doesn't work normal as before.


and i noticed it's working if i open the deb file from open item in menu of gdebi interface, but i don't know why it isn't working directly by click on the deb file as normal

Please relay the output of

cat /usr/share/applications/gdebi.desktop

[Desktop Entry]
Name=GDebi Package Installer
GenericName=Package Installer
Comment=Install and view software packages
Exec=gdebi-gtk %f
Icon=gnome-mime-application-x-deb
Terminal=false
Type=Application
Categories=System;
MimeType=application/vnd.debian.binary-package;
NotShowIn=KDE;
X-Ubuntu-Gettext-Domain=gdebi
StartupNotify=true
Keywords=package;apt;dpkg;install

Looks fine...
What about:

dpkg -L gdebi | grep policy

/usr/share/polkit-1/actions/com.ubuntu.pkexec.gdebi-gtk.policy

Also looks good.

Are you running gdebi by clicking a .deb icon that is on the desktop? What about if it is in a folder like ~/Downloads?

that .deb files in documents and try open .deb files in downloads , but not working too.
i tried changing in the command of gdebi in gdebi.desktop, instead of

gdebi-gtk %f
i tried
sh -c "gdebi-gtk %f"
and that solved the problem, i don't know what the difference.

That is a shell command. It really is not a proper fix...

in the recently days , i remembered that i tried to install commands and tried to run gvfsd-admin daemon to open folder as admin(thunar admin://%f), may be that effect on that , and played a lot with pkexec command, i don't know.
i searched for gdebi in this site, and i found that sh -c "gdebi-gtk %f" in post 19 and found make terminal true in post 16, and the two worked, but i did that in the launcher of the zorinmenu

@eid

I am actually concerned about this...
Running it as you are, with potential Authentication issues, may create a security hole in your system.
I would rather not go into detail, publicly, what the above entails.

Plus, you may experience further issues with authentication after a package upgrade - and with other packages as well.
While this 'solution' may suffice for now... I Highly Advise that you back up all personal files and consider a re-install of Zorin OS Lite.
While it may seem tedious, in the long run, you want a fully intact and operational authentication system.

i don't think that is dangerous: