Gdm.service stuck

I'm experiencing gdm.service crashes/freezes when I boot into Zorin OS so it doesn't work for a long time (I waited about 30 minutes), then I turn it off by pressing the poweroff button. When trying to use the kernel recovery mode it booted quickly but when trying to go through the kernel, I had the problem again. Is this a bug? Should I go through? Thank you.

After that I tried again through kernel recovery mode and tried several menus such as dpkg, fsck and clean found no problems, then I chose normal boot. and it worked. I ran

sudo fsck -y

found no problem and tried restarting GDM with `

systemctl restart gdm.service

`. then I rebooted and tried to boot again successfully (gdm.service not stuck/freeze) and fast.

1 Like

If my memory serves me correctly, (most often it don't) FSCK is Linux version of Windows Checkdisk. Believe it or not, I have gone through the same thing on Windows before with that message you got returned.

I remember years ago on Windows, I had some issues, and so I ran check disk, it said there were no problems, but suddenly, things were working correctly.

So the lesson just goes to show, just cause it says there are no problems, don't mean there are none. There was obviously a problem, and that command obviously fixed it.

Because the only way I'd truly believe there wasn't a problems, well, logic would dictate that you had some phantom code stuck in the RAM, that got whipped out of the buffer when you restarted.

I guess either could be the case. But I am going to error on the side of caution, and say that your commands are what fixed it lol.

I re-experienced this problem randomly(sometimes normal sometimes problematic). what do I have to do? is there any other way?


Der Panzer, are you using Nvidia graphics?

There are many things that can cause this. So finding which and sorting it out may be more trial and error than one click fix.

You might try sudo apt install -f or you may need to reinstall the kernel, zorin desktop and gdm all at once.
Or switching to a different display manager may resolve the issue, like SDDM or LightDM.
Finally, reinstalling Zorin OS, if viable given yuor risk of data loss, may be the way to go.

I used Intel Graphics, I tried installing DE Cinnamon and XFCE4 to fix this, and several times to boot, did not experience stuck back. I don't know what this has an effect or not. But I lost the Zorin screen lock (after installing Cinnamon), can I change the Zorin screen lock back?

Can you see if you installed another DM

sudo apt remove --purge sddm lightdm

Then ensure that your Zorin Desktop files are all intact:

sudo apt install zorin-os-desktop gnome gnome-shell gdm3

For gdm3, it should offer a Reconfiguration of GDM in the Terminal during the installation, so please keep an eye on it.

Cinnamon and XFCE are both easy to install and relatively painless. i wonder if a Net Connection Drop may have corrupted a package.

After running: sudo apt remove --purge sddm lightdm and sudo apt install zorin-os-desktop gnome gnome-shell gdm3 then reboot. Smoothly until the Z and Zorin logo appears then just black screen. I press power off then the recovery kernel then selects the normal boot kernel and then changes to the Command Line Interface. Then I run sudo apt install sddm lightdm then select the default desktop manager to gdm and reboot. Now return to normal as usual.

That is interesting... GDM did not work unless yo utried installing another DM, then selected GDM?

Do you have three DM's installed, now?

Yes, maybe I have 3 desktop manager. I will try

sudo dpkg-reconfigure gdm3

to set the desktop manager then delete another desktop manager.

Maybe this caused a problem?

Are you also using Autologin?

Yes, I used autologin.

1 Like

What are the contents of /etc/gdm3/custom.conf ? You can use pastebin to relay the output.

1 Like

2 Likes

Well, I was going to suggest two things:

AutomaticLoginEnable=true

WaylandEnable=false

The first one you already have set. The second one, you can remove the ( # ) hashtag and add =false.
Then test...

1 Like

Thank you for the help. I've been waiting for a few days. not having that problem again.

1 Like