Getting a black screen on restart

Just a strange issue with ZorinOS. Once the install completed, and now after every time I click on Restart, the OS exits to a black screen and hangs there. I have to force a shut down. Tried clicking and pressing enter but that didn't do anything. Any idea as to how I might address this?

Install of Zorin is the Nvidia option, as I have a GeForce 1650 card. System is GPT - Zorin installed with UEFI - Secure Boot is disabled so far as I know. MSI mobo - GD65 gaming.

Can you please open terminal and add the driver repository:

sudo add-apt-repository ppa:ubuntu-x-swat/updates

Then update and upgrade:

sudo apt update && sudo apt full-upgrade

and test your graphics...

1 Like

Gimme a sec to send this link to my email so I can open it in Zorin, and I will do as requested.

N00b Linux user here... How do I test the graphics?

1 Like

Reboot and see if the screen behaves.:wink:

Huh I guess I can stop calling myself a n00b, because I at least knew to run these in Terminal...

Problem fixed! Guess I missed a step on the first time install of ZorinOS. I have updated Lutris and Wine. I also got Flathub and the store working. Anything else I might have missed?

BIG virtual hug, handshake or fist bump - whichever is your preference. Thank you!

1 Like

That's not a missed step, just part of Life On Linux when you have Nvidia.:wink:

@DreamBliss Whilst you are checking things. Check that your Software Updater is set to "Main Server" for best resuts instead of a local country server.


Where do I check this? I recall seeing something about it in a video...

From the app menu, search (Just start typing) for Software & Updates
Click it open, and right there on the First Tab is a Download From option, with a drop down menu. Ensure that drop down menu is set to Main Server.



1 Like

So no Software & Updates option. But I do have a Software Updater, which I ran and which promptly failed. Went into Settings/Zorin Software/Download From, selected US Servers, had it choose the best one, entered my password, and a base update for Zorin ensued. However on running it again it failed to get the repository information again. Not sure what is up with that. But now it says, running it yet again, that everything is up to date.

Open the Zorin App menu and type in Software & Updates and it should offer it right up.
As soon as it opens, the first tab is the one shown that has Download from with a drop down menu. Select "Main Server."

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.