Getting flatpak metadata for flathub

file:///home/koolandrew/Downloads/zorin%20issue.png

Does anyone know what to do here, as the software hasnt worked for a while, this specific error is new.

Can you please open a terminal with
ctrl+alt+t keyboard shortcut
Run

sudo apt update && sudo apt dist-upgrade

Once done, please reboot
Then, ctrl+alt+t to open terminal, then run:

flatpak update

1 Like

Thanks very much for the reply, it is 10x better now. Are they ways of installing other linux repositories (not sure that is the right word) like snap.

Snap comes built in, along with the Zorin OS flatpak and the APT repositories.
You shouldn't need to do anything extra for them to work.
Installing snaps can be done with the Software store. When you select a package, look at the upper right side on the titlebar for a Sources button that can show whether the package is available for Flat, Snap or Apt.

Or it can be done in terminal with

snap install example-package-name

Thanks very much, unfortunately, the current one is barely usable. I do a search the search icon spins and not much else. Even when click an icon, it doesnt really work, the search just spins. I am not sure if it is related to the flatpak issue but it is unforuate as the software has been good otherwise.

Have you yet tried:

killall gnome-software

Remove the ~/.config/gnome-software directory.
Run

sudo apt install --reinstall ca-certificates gnome-software

hi, could you please guide on removing the directory as i would imagine that i need to switch to root access, however i dont seem to have a different access level to the computer and have very limited directory access.

thx

The tilde symbol (~) is shorthand for your Home directory.
So when you see any path referenced using ~, it means that is in Home, not Root.
If you are not seeing the .config directory, then tap ctrl+h to reveal "hidden" folders and files.

I went to the file directory instead of using the terminal and was able to see config but there no file as listed above to remove?

If it is not there, then no need to remove it. :slight_smile: