Getting Linksys WUSB6300 V2 to work on ZORIN OS 16

I need help to install the drivers for the usb adapter, I have tried doing it from the unbuntu fourms, but had no luck.

1 Like

This person said that they successfully installed it. Please see if this can help you out?
https://forums.kali.org/showthread.php?47019-Successfully-installed-Linksys-WUSB6300-(rtl8812au)

1 Like

I will try it

1 Like

I actually tried that one earlier and it didn't work.

1 Like

And you are saying that this one didn't help you at all?

There is this other one...
https://itectec.com/ubuntu/ubuntu-how-to-get-the-linksys-wusb6300-wireless-adapter-to-work-on-linux/

The guys over at BleepingComputer were talking about this too.

1 Like

I tried that unbuntu one, I'll try bleepingcomputer

1 Like

I'll work on this tomorrow, I actually checked those all out previous to which is why I am posting on the forums.

1 Like

@chutson1 Hi

Steps to make Linksys WUSB6300 V2 work on ZorinOs16 [ALL VERSIONS]:

  1. The terminal part:
    Ctrl + Alt + T ←(Open the Terminal)
    $ sudo apt install git dkms ←(Installs Git and DKMS)
    $ git clone https://github.com/aircrack-ng/rtl8812au.git ←(Copies the Git repositories - GitHub - aircrack-ng/rtl8812au: RTL8812AU/21AU and RTL8814AU driver with monitor mode and frame injection)
    $ cd /#where you copied it/rtl8812au ←(Goes to the place where you cloned the GitHub repo)
    $ sudo ./dkms-install.sh ←(Installs it)

  2. Reboot:
    $ reboot / MenuReboot

  3. Enjoy:
    It should work properly now :sunglasses:

If you have any problems ask here, make sure to also give detailed information - (Copy and Paste the output if the commands don't work) (List any error you encounter). :+1:

Sources:

Hope this helps :crossed_fingers::four_leaf_clover:

2 Likes

@chutson1 Did it work?