Getting Viber to work again

Hello All

Zorin finally allowed me to make the leap into Linux as a Windows replacement. Now my general office PC.
I installed Viber not long after the transition and all worked perfectly for several weeks. Then all of a sudden Viber's desktop Ikon disappeared. After several attempts at removal & reinstallation, the app just won't start up.

I have hit a dead end as to what's next, anyone in the same boat?

Appreciate any help.

Is Viber install as a Flatpak?
Recommend using the .deb package for Viber.

1 Like

I am in the same boat. Installed it from the store, worked great a long time. Then suddenly did not start anymore. Before that I had a short time to click the icon twice, means first time it did not open the window, the second time all was ok.

I tried to uninstall and reinstall from the store. No help.

Then I tried to install the .deb, no help.

Chances are then it may be a bad update from Viber themselves in which case there is nothing Zorin or anyone else can do about that but Viber.

I headed over to Viber and they have an Appimage for download on Linux. Why don't you try that instead of going through the store. You don't only have to install software that is in the store.


Thanks for your replies all. Appimage didn't help.

Then I thought I had a brainwave and decided to try the Win version through Wine, however it can't see the Internet. Like sticking the big toe into a pond, where you can't see the bottom. lol.

I'll crack this when I get time. Manged to get my 2008 Quickbooks going on a Win10 laptop, so anything is possible.

I asked viber by emai, about the problem (it didn't work in other linux distributions I have used), and their answer was: we don't support linux!!!
I replied that i could communicate through signal and telegram instead then.


Weird that they have a Linux version to download & it worked perfectly for a couple of months?


Is this the package you used?

All dependencies are easily satisfiable.

However, I tested the .deb above by running it through Lintian.
It produced a lot of errors, including bad or malformed md5sum.
Most of the rest of the 'errors' are quite minor.
If you install the above .deb, it should replace all the files in your current /opt/ directory with the ones from the .deb. So if you used the above previously; and you run it now... it should work again.
If it is not working:
Have you recently installed any other new software that required compiling or altered / modified / upgraded any of the dependencies that Viber shares?
If you have recently installed software, you may know off-hand whether it was installed in the same time frame as when Viber began to fail.

I went through this with Viber. Their help desk give up easily, blaming the issue on Zorin, me, wrong software, etc, etc. When I finally got Viber to install and attempt to register me, he continues to come back saying my phone number if invalid. That's where I'm stuck right now......

1 Like

I also contacted Viber once because their mobile app is getting larger and larger and there is no possibility to clear the cache of received media. On other messenger apps this is possible. But they said this is not possible or anything like that, means for me they don‘t want to do it.

You have all convinced me to never use Viber. I mean... Not that I would have, anyway...

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.