Gigabyte X570S Aorus Master WiFi Not Working

I am using the latest version of Zorin OS 16 on my desktop and have been unable to get the onboard WiFi or any external WiFi adapters to work. I am very new to the Linux scene so I am unfamiliar with most troubleshooting steps. Any help is appreciated.

ethan@ethan-ZorinOS:~$ sudo inxi -Faz
System:
Kernel: 5.11.0-44-generic x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/boot/vmlinuz-5.11.0-44-generic
root=UUID=8d98680e-c522-4489-8c8e-d5e9dea9a2d8 ro quiet splash
vt.handoff=7
Desktop: Gnome 3.38.4 wm: gnome-shell dm: GDM3 3.38.2.1
Distro: Zorin OS 16 base: Ubuntu 20.04 LTS Focal
Machine:
Type: Desktop System: Gigabyte product: X570S AORUS MASTER v: -CF
serial: N/A
Mobo: Gigabyte model: X570S AORUS MASTER v: x.x serial: N/A
UEFI: American Megatrends LLC. v: F3b date: 09/06/2021
Battery:
Device-1: hidpp_battery_1 model: Logitech Wireless Mouse MX Master 3
serial: charge: 100% (should be ignored) rechargeable: yes
status: Discharging
CPU:
Topology: 8-Core model: AMD Ryzen 7 3700X bits: 64 type: MT MCP arch: Zen
family: 17 (23) model-id: 71 (113) stepping: N/A microcode: 8701021
L1 cache: 512 KiB L2 cache: 4096 KiB L3 cache: 32.0 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
bogomips: 115198
Speed: 2198 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz):
1: 2174 2: 2068 3: 2035 4: 2200 5: 2124 6: 2131 7: 2190 8: 4269 9: 2106
10: 2192 11: 2437 12: 2241 13: 2130 14: 4234 15: 2174 16: 2199
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
vendor: Sapphire Limited driver: amdgpu v: kernel bus ID: 0c:00.0
chip ID: 1002:731f
Display: server: X.Org 1.20.13 driver: amdgpu compositor: gnome-shell
resolution: 2560x1440~144Hz, 1440x900~60Hz
OpenGL: renderer: AMD Radeon RX 5700 XT (NAVI10 DRM 3.40.0
5.11.0-44-generic LLVM 12.0.0)
v: 4.6 Mesa 21.0.3 direct render: Yes
Audio:
Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel
bus ID: 0c:00.1 chip ID: 1002:ab38
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel bus ID: 0e:00.4 chip ID: 1022:1487
Sound Server: ALSA v: k5.11.0-44-generic
Network:
Device-1: Intel driver: iwlwifi v: kernel port: N/A bus ID: 05:00.0
chip ID: 8086:2725
Device-2: Intel vendor: Gigabyte driver: igc v: kernel port: N/A
bus ID: 06:00.0 chip ID: 8086:15f3
IF: enp6s0 state: down mac:
Device-3: NetGear A6100 AC600 DB Wireless Adapter [Realtek RTL8811AU]
type: USB driver: usb-network bus ID: 7-1:2 chip ID: 0846:9052
serial:
IF-ID-1: usb0 state: unknown speed: N/A duplex: N/A mac:
Drives:
Local Storage: total: 465.76 GiB used: 177.64 GiB (38.1%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 980 500GB size: 465.76 GiB
block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
serial: rev: 1B4QFXO7 scheme: GPT
Partition:
ID-1: / raw size: 465.26 GiB size: 456.96 GiB (98.22%)
used: 177.63 GiB (38.9%) fs: ext4 block size: 4096 B dev: /dev/nvme0n1p2
Sensors:
System Temperatures: cpu: 61.9 C mobo: N/A gpu: amdgpu temp: 16 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
Processes: 407 Uptime: 1h 00m Memory: 31.29 GiB used: 9.27 GiB (29.6%)
Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9
Shell: bash (sudo) v: 5.0.17 running in: gnome-terminal inxi: 3.0.38

Please try the code posted in the third-to-last post by chili555 on this thread: [SOLVED] Rtl8811au

Second suggestion, if above one doesn’t work: wireless - Driver rtl8811au for usb wifi - Ask Ubuntu