Gionee s10cl firmware flashing failed

I by mistakenly loaded my Gionee s10cl with spreadtrum instead of Qualcomm
And my phone turned out to off immediately after booting, I've tried to install new firmware on it, but I ended up receiving a failed message over and over again
I've tried many Qualcomm device tool flashing tools but it's keep failing
I've tried my all best but it's keep failing to I've tried another PC, uninstall the driver but it's keep failing please help

You may need to reach out to the applicable Gionee help desk.
Flashing cellular phones may be beyond the scope of this Forum.

Is it giving IO errors when you're trying to flash? You may have to add your user to the dialout group, if not already. Which software are you flashing with? If it's Android, you may be able to flash over ADB / fastboot.. And installing libusb-dev helps a bit, too. My big hang ups were dialout, and just not starting the flashing app with sudo.

You can see if it is dialout related, you can chmod the USB to enable writing over that port. If it's /dev/ttyUSB0, try: sudo chmod 600 /dev/ttyUSB0 and then try the flashing again - then you can add yourself to dialout if it works: sudo usermod -a -G dialout $USER. That prevents you from having to chmod the USB port to write over wire to device every time you want to flash.. But, just a few stabs in the dark lol ADB / fastboot will need downloading, not too bad, I use the portable version, smaller.