Gnome 3 finger swipe not working

Hi I did a fresh install of zorin and had gnome 3 finger swipe installed but it isn't working. I ran this cmd: ```
libinput debug-events and this is my output:

$ libinput debug-events
Failed to open /dev/input/event1 (Permission denied)
Failed to open /dev/input/event0 (Permission denied)
Failed to open /dev/input/event2 (Permission denied)
Failed to open /dev/input/event4 (Permission denied)
Failed to open /dev/input/event5 (Permission denied)
Failed to open /dev/input/event8 (Permission denied)
Failed to open /dev/input/event9 (Permission denied)
Failed to open /dev/input/event12 (Permission denied)
Failed to open /dev/input/event6 (Permission denied)
Failed to open /dev/input/event11 (Permission denied)
Failed to open /dev/input/event7 (Permission denied)
Failed to open /dev/input/event3 (Permission denied)
Failed to open /dev/input/event10 (Permission denied)
Expected device added events on startup but got none. Maybe you don't have the right permissions?

Any ideas?

Have you added your user account to the input group, then rebooted the computer?

thanks I will try that now.

That didn't work.

Have you installed the libinput-gestures app? If so, you might try removing it and using TouchEgg application

sudo add-apt-repository ppa:touchegg/stable

sudo apt update && sudo apt install touchegg

sudo systemctl start touchegg

To set it to run at each boot:

sudo systemctl enable touchegg.service

Ensure that the Gnome Shell Extension X11 Gestures is installed;

sudo apt install --reinstall gnome-shell-extension-x11gestures

Launch X11Gestures configuration to set up.

I have followed the steps above but no difference. In addition, I downloaded the gnome extension for brave. I have this error at the top of the page.


When I wanted to fix it it didn't work.
Also I am not logged in to gnome there but I don't recall having to do that last time and it worked.

The X11Gestures extensions is included in Zorin OS Core.

And I have downloaded extensions manager and can see the x11 gestures turned on as well. But not working all I can do is 4 fingers down to go to desktop.

My experience and knowledge of Gnome Shell Extensions is more limited. I may need to bow out on this one and let a better person try to help.

1 Like