Gnome calendar readability and touch tap login?

Hello fellow nerds,

I switched to linux about a year ago. It is still a bewildering and confusing world for me a lot of the time but I am learning a thing or two.

Anyway, I am using Zorin lite. I have set up the mouse to work with a tap touch and it works. However, on the login screen I have to actually click to login. This may seem a trifle to some but not to a raging control freak such as myself.

Another thing which is bugging the hell out of me is that when I use gnome calendar and then choose a dark theme in ‘Appearance’, the entries become completely illegible. I need to be able to change the font colour in gnome calendar. I’ve looked for other calendars but none seem to match the utter simpicity of the gnome one.

Anyway, any help from the community would be much appreciated and I will to try and pass it on in some way.

Best

Matt

You will need to go root

pkexec thunar

Navigate to ’ /etc/X11/xorg.conf.d/ ’
Right click and create a new document
Paste this in, then save it.

Section "InputClass"
    Identifier      "Touchpad"                      # required
    MatchIsTouchpad "yes"                           # required
    Driver          "synaptics"                     # required
    Option          "MinSpeed"              "0.5"
    Option          "MaxSpeed"              "1.0"
    Option          "AccelFactor"           "0.075"
    Option          "TapButton1"            "1"
    Option          "TapButton2"            "2"     # multitouch
    Option          "TapButton3"            "3"     # multitouch
    Option          "VertTwoFingerScroll"   "1"     # multitouch
    Option          "HorizTwoFingerScroll"  "1"     # multitouch
    Option          "VertEdgeScroll"        "1"
    Option          "CoastingSpeed"         "8"
    Option          "CornerCoasting"        "1"
    Option          "CircularScrolling"     "1"
    Option          "CircScrollTrigger"     "7"
    Option          "EdgeMotionUseAlways"   "1"
    Option          "LBCornerButton"        "8"     # browser "back" btn
    Option          "RBCornerButton"        "9"     # browser "forward" btn
EndSection

The above is for using libinput. This should work right away on your next log in.

Otherwise you can try

sudo apt install xserver-xorg-input-synaptics

Does Zorin Lite use Gnome calendar? I thought it used xfce4-datetime-plugin…

Hello. Thank you for your reply. You are overestimating my skills. How do I ‘go root’? I tried to navigate to the file and got to ‘X11’ but there was no /xorg.conf.d/ folder. The ‘create new document’ was greyed out because I was not in root I suppose. Forgive my ignorance.

I downloaded gnome calendar to use as a timetable. It’s the only one I like but it hard to read when a dark theme is applied.

Thanks in advance for your help here.

Best

Matt

Use sudo thunar , then it will fire up with root access.

I can forgive ignorance easily, as I have plenty of my own. What I cannot forgive is Choosing Ignorance :smiley:

To open a terminal, press all at the same time Ctrl Alt and t

ctrl+alt+t

Enter into it

pkexec thunar

or as Carmar said

sudo thunar

Both will achieve the same goal, but pkexec is aimed toward using ‘sudo’ to operate a Graphical Application.
The command ‘sudo’ stands for SuperUserDO as in, Do-this. SuperUser is the user account to access Root.
The way Linux file system is structured is similar to your Android Phone. This makes sense since Android is based on Linux, though it has diverged with ARM to become different enough to no longer be interchangeably compatible.
You operate normally from /home/$USER/
where $USER is the username you had set up during installation. This is abbreviated, in terminal and elsewhere, to ~/. You may often see a path specified on the forum to go to your pictures folder looking like ~/Pictures.
The system files are elevated above this Home Directory. Just like your droid, this is to keep them a bit isolated to prevent system damage from user mistakes. This is just / or Root and can only be changed with a password. That is the root password you also set up during installation and the same one you log in to your desktop after bootup with.
You are spot on that the option to create a new folder was greyed out because you were not operating with Root Privileges.
When you “pkexec thunar”, you will get a password prompt. Enter that, then navigate to /etc/X11/ and from within the X11 directory, right click, choose create new folder, rename that new folder from Untitled to

xorg.conf.d

Double click to enter it, then right click, create new document and name that

40-synaptics.conf

Once that is created, copy the above code in the previous post and paste it into the new created 40-synaptics-conf file and save it.
Then log out and back in to test.

If that does not work… when you move to log in; tap-touch is nto working, then log in and open terminal (ctrl-alt-t) and enter into it

sudo apt install xserver-xorg-input-synaptics

Check the terminal output and make sure it installed successfully.
Then log out and in to test.

Makes sense. Could you post a screen shot of both theme usage on the calendar? You can take a screenshot with one button push by hitting the prt-scrn key. It saves to your Pictures folder automatically.
Screen shots can be uploaded to the forum with either Markdown language tags or by hitting the Image icon on the toolbar over the posting text area when composing the post.

Ah ok. Thank you,

Ok, I got the tap touch to work. Thank you very much for your kind help. I have learned something new. However, and I feel nervous about admitting this, I have today hopped over to elementary and the calendar thing is no longer an issue. I hope you can forgive me. I mean it's still ubuntu right? But who knows, I may well be back onto Zorin at some point.

There is absolutely nothing to be embarrassed or nervous about.

Zorin OS is a Great distro. But part of the beauty of Linux is the diversity and the ability to "test different flavors." Many distros offer different setups, different ways of working, that appeal to different people.

I myself, am not using Zorin OS right now and I have not been for a little while. I even forget sometimes, when I move to check a Zorin Specific file, then remember I do not have that... and I need to go about referencing it some other way in order to help the user on the forum. Come to think of it... Currently there are no computers in my house running Zorin OS. When it used to be Four running Zorin only a couple months ago.
Part of being in Linux includes exploring what other distros have to offer and comparing notes on it with other Linux users.

And part of my bias: Even when using Zorin OS; I used the Cinnamon Desktop Environment instead of the Default that comes with Zorin OS, so some things always worked differently. Plus, as I make my own Icon Sets and Themes, I often have wildly different appearances to apps than others do.
Even my terminal is z-shell (zsh) with P10K installed, so it looks and acts differently than the terminal many members are used to. :wink:

You are part of the Linux Crowd, now - Zorin OS or not.

I agree, as usual, with Aravisian. There is nothing wrong with going with a different distro. The beauty with Linux, is it gives you choices. If you find a distro that is more to your liking, and does what you need it to do, that is the one you should go with.

And I too would like to thank you personally, for being a member of the Linux community. The larger our community, the more people will know about how awesome Linux is. So congrats, and know, we are always happy to help. :slightly_smiling_face:

1 Like

Tried both the solutions suggested here. The first one did nothing. The second one rendered both my keyboard and mouse unusable on login. I wasn't happy to say the least as I had to reinstall from scratch which means I lost all the work I did yesterday. I am on Zorin lite. Surely there is a way to edit the login screen so it follows the theming of the desktop and allows tap touch. It's wierd that the developers didn't make this automatic. Bloody computers!