Gnome extension "system-monitor-next"

Hi all,
I switched from Debian 12 to the new Zorin 17 and enjoying it so far: runs on my daily working computer flawlessly and beautifully for the moment.
One minor issue : I cannot use gnome extension called "system-monitor-next", which I have used in Debian. It should show the usage of system resources in the status bar.

I tried versions for Gnome 42 (default for Ubuntu 22.04) and Gnome 43, and even 44-45, but it gives always the same error : "meta is null" whatever it means.

I mean, it is minor thing indeed (I am using "vitals" for the moment - it gives similar info, just without graphics), but I wonder if anyone of Zorin community succeeded to run it?

Thanks for your help!

How do You installed it? Over the Gnome Extensions Website? With the Extension Manager?

Via Web-site, while I cannot find it in "Extension manager"

Spontaneously I would think that you maybe have the wrong Version. The Extension is available in the Extension Manager. Look here:

As You can see, I simply typed in the Search Line: system-monitor-next

I would suggest the Trial that you uninstall Your Version and then You try it with the Version from the Extension Manager. I hope that this works for You.

First of all, thank you for your help!

Indeed, I had the results of search sorted by popularity, and saw no relevant item. The I sorted it by the most recent items, and got it :

Nevertheless, unfortunately, it gave the same error.

1 Like

As per this thread, you might want to install some missing dependencies:

sudo apt install gir1.2-gtop-2.0

Sorry, that it didn't work.

Thank you, I installed the suggested libraries: gir1.2-gtop-2.0 and gir1.2-nm-1.0 (as suggested in the thread you haver shown), but still it didn't work.

Anyway, thank you all for your help!

Does the extension install at all? If it does, remove it and install all of the dependencies listed in the main page of the repository (scroll down to the Ubuntu section).
I just tried again on a separate fresh install and it works normally.

sudo apt install gir1.2-gtop-2.0 gir1.2-nm-1.0 gnome-system-monitor

Although I see that there's an issue reported from yesterday with the exact same error message. So it may be something else entirely. Keep an eye on that issues for any potential fixes from the developers.

Did as you've said : deleted the extension by extension manager, installed above mentioned dependencies, and installed the extension from gnome-extensions site.

Worked fine. Thank you very much.

1 Like

Glad it worked!

Could I ask you to mark the post above as the solution to this thread? It'd be helpful for any future searches from people experiencing the same issue. Cheers!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.