Gnome-network-displays problem connecting chromecast

I cannot connect my chromecast with gnome-network-displays.
I have the following error message :

bt@zero:~$ flatpak run org.gnome.NetworkDisplays

(gnome-network-displays:2): Gnd-ERROR **: 14:42:38.557: CcHttpServer: Failed to create gst elements
bt@zero:~$ 

I'm using zorin 17 pro on an Asus vivobook a quite linux friendly laptop.

Anybody has any clue to solve this ???

More info on my environment here

bt@zero:~$ inxi -Faz
System:
  Kernel: 6.5.0-28-generic x86_64 bits: 64 compiler: N/A
    parameters: BOOT_IMAGE=/BOOT/ubuntu_hwmpxp@/vmlinuz-6.5.0-28-generic
    root=ZFS=rpool/ROOT/ubuntu_hwmpxp ro quiet splash vt.handoff=1
  Desktop: GNOME 43.9 tk: GTK 3.24.33 wm: gnome-shell dm: GDM3 42.0
    Distro: Zorin OS 17.1 base: Ubuntu 22.04 LTS Jammy
Machine:
  Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X513UA_M513UA
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: X513UA v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: X513UA.305 date: 03/12/2021
Battery:
  ID-1: BAT0 charge: 19.7 Wh (65.0%) condition: 30.3/42.1 Wh (72.0%)
    volts: 11.8 min: 11.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
    status: Discharging cycles: 84
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M325
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: Discharging
CPU:
  Info: model: AMD Ryzen 7 5700U with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 family: 0x17 (23) model-id: 0x68 (104) stepping: 1
    microcode: 0x8608103
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 8 MiB desc: 2x4 MiB
  Speed (MHz): avg: 461 high: 1388 min/max: 400/4372 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 400 3: 400
    4: 400 5: 1388 6: 400 7: 400 8: 400 9: 400 10: 400 11: 400 12: 400
    13: 400 14: 400 15: 400 16: 400 bogomips: 57494
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed
    mitigation: untrained return thunk; SMT enabled with STIBP protection
  Type: spec_rstack_overflow mitigation: Safe RET
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Lucienne vendor: ASUSTeK driver: amdgpu v: kernel pcie:
    gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
    active: eDP-1 empty: HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:164c
    class-ID: 0300
  Device-2: Quanta USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 3-3:4 chip-ID: 0408:30d4 class-ID: 0e02 serial: <filter>
  Display: wayland server: X.org v: 1.21.1.4 with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: X: loaded: amdgpu,ati
    unloaded: fbdev,modesetting,radeon,vesa gpu: amdgpu display-ID: 0
  Monitor-1: eDP-1 built: 2018 res: 1920x1080 dpi: 142 gamma: 1.2
    size: 344x194mm (13.5x7.6") diag: 395mm (15.5") ratio: 16:9 modes:
    max: 1920x1080 min: 640x480
  OpenGL: renderer: RENOIR (renoir LLVM 15.0.7 DRM 3.54 6.5.0-28-generic)
    v: 4.6 Mesa 23.2.1-1ubuntu3.1~22.04.2 direct render: Yes
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 03:00.1 chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor
    vendor: ASUSTeK Raven/Raven2/FireFlight/Renoir Processor driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x,
    snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps, snd_sof_amd_renoir,
    snd_sof_amd_rembrandt
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
    bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound Server-1: ALSA v: k6.5.0-28-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 01:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-2:6 chip-ID: 8087:0029 class-ID: e001
  Report: hciconfig ID: hci0 rfk-id: 4 state: up address: <filter>
    bt-v: 3.0 lmp-v: 5.2 sub-v: 237e hci-v: 5.2 rev: 237e
  Info: acl-mtu: 1021:4 sco-mtu: 96:6 link-policy: rswitch sniff
    link-mode: peripheral accept
    service-classes: rendering, capturing, audio, telephony
RAID:
  Device-1: bpool type: zfs status: ONLINE level: linear raw: size: 1.88 GiB
    free: 1.57 GiB allocated: 307 MiB zfs-fs: size: 1.75 GiB free: 1.45 GiB
  Components: Online: N/A
  Device-2: rpool type: zfs status: ONLINE level: linear raw: size: 944 GiB
    free: 567 GiB allocated: 377 GiB zfs-fs: size: 914.75 GiB free: 537.44 GiB
  Components: Online: N/A
Drives:
  Local Storage: total: raw: 1013.56 GiB usable: 1.88 TiB
    used: 318.89 GiB (16.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: PC SN530 SDBPNPZ-1T00-1002 size: 953.87 GiB block-size:
    physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
    serial: <filter> rev: 21106000 temp: 35.9 C scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 type: USB model: Multiple Card Reader
    size: 59.69 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: 1.00
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  ID-1: / raw-size: N/A size: 544.91 GiB used: 7.48 GiB (1.4%) fs: zfs
    logical: rpool/ROOT/ubuntu_hwmpxp
  ID-2: /boot raw-size: N/A size: 1.75 GiB used: 305.1 MiB (17.0%) fs: zfs
    logical: bpool/BOOT/ubuntu_hwmpxp
  ID-3: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 20.1 MiB (3.9%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-4: /var/log raw-size: N/A size: 537.7 GiB used: 271.6 MiB (0.0%)
    fs: zfs logical: rpool/ROOT/ubuntu_hwmpxp/var/log
Swap:
  Kernel: swappiness: 10 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 2 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/dm-1 maj-min: 252:1 mapped: cryptoswap
Sensors:
  System Temperatures: cpu: 41.0 C mobo: N/A gpu: amdgpu temp: 40.0 C
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 602 Uptime: 4h 11m wakeups: 35 Memory: 15.02 GiB
  used: 9.14 GiB (60.8%) Init: systemd v: 249 runlevel: 5 tool: systemctl
  Compilers: gcc: 11.4.0 alt: 11/12 Packages: 2689 apt: 2610 lib: 1305
  flatpak: 70 snap: 9 Shell: Bash v: 5.1.16 running-in: gnome-terminal
  inxi: 3.3.13

According to this web page, pipewire is needed:

Zorin is using pipewire version 0.3.48-1ubuntu3 and the flatpak info says that it need pipewire 0.3.8 or more. So this may be the culprit. Zorin didn't install the correct version. I'm not sure if I can upgrade to 0.3.8 without causing others problem since pipewire is made of few libraries and binaries and is used by other apps. It seems that gnome-network-displays as installed by zorin is unusable.

Last version of pipewire is 1.0.5 dated 2024-04-15. Pipewire passed 1.0.0 version since the beginning 0f 2024. We need a more recent version on Zorin...

PS: I don't get why this flatpak has dependencies on the host ???

Not sure if this could work for you:

I will try at home tonight.
Thanks :+1:t2:

The article is a bit old. But I used the README to install all reported dependencies.
I'm still strugling to find one dependency to be able to compile gnome-network-displays
I'm stuck at this error :

Found CMake: /usr/bin/cmake (3.22.1)
Run-time dependency gtk4 found: NO (tried pkgconfig and cmake)

src/meson.build:36:0: ERROR: Dependency "gtk4" not found, tried pkgconfig and cmake

Update: I have installed libportal-gtk4-dev and it seems to be ok but now I don't have a enough recent version

src/meson.build:36:0: ERROR: Invalid version of dependency, need 'libportal-gtk4' ['>= 0.7'] found '0.6'.

I'm afraid I cannot compile gnome-network-displays 1.1 on zorin gnome 42 ...
:roll_eyes:

I share your frustration. I have been having similar experiences on pclinuxos, not in terms of screen sharing but other apps, but slowly getting there, baulked by another dying hard drive, this time a Samsung drive. See if you can find an online source. One of the apps I had been having issues with was a lack of the app, Linux Intelligent OCR Solution (LIOS), currently at version 3.0 but only available from GitLab and had to sign up for an account to download the source code. Couldn't get any further until I found version 2.8.1 on Sourceforge. Fortunately, just before hard drive failure, I had to install 2 dependencies that were available via Synaptic and in order to get it to run, I had to:

chmod 775 lios

so that I as a user instead of root, could launch it.