Gnome Software Icons Messed Up

So a couple of months ago I wanted to try KDE plasma on my Gnome Zorin Installation and I kinda messed some things up, since I didn't exactly know what I was doing. I was able to get most of my stuff back, however the gnome-software store's icons theming seem to be messed up. It's not that big of an issue however if anyone knows any fix, would me much appreciated!

Can you remove the Breeze Icon set and Oxygen Icon set that Plasma adds?

I strongly recommend using Synaptic Package Manager for this task just to make your life easier and reduce stress.

sudo apt install synaptic

Launch Synaptic, then look to the Search Entry on the top toolbar.
There are three keywords that you want to search.




Not all KDE stuff should be removed, so just wiping anything marked as K-something or KDE-something may not be the best route. But you can remove anything related to Breeze theme, Oxygen theme and Plasma. So remove all of those by selecting them as "Completely remove" and clicking the apply button.

Alright, I have done as you said! However it seems to have little to no effect at least in the gnome-software side of things, same theme parsing error. Would a gnome-software reinstall do the trick?

Have you reset your themes in Zorin Appearance and logged out / logged in or Rebooted?

Yep, however when I press "reset to defaults" nothing appears in the box, is this the expected behaviour? (sorry can't remember how it was before)

Have you selected your Applications Theme, Icon theme and Gnome Shell theme from the drop down menus on the right?

Nope, only three options appear from the drop down menus, adwaita, adwaita dark and high contrast, the only way to get the one I currently use, that is the Zorin gnome default i believe, only works when clicking "reset to default"

Please run in terminal:

sudo apt install --reinstall zorin-os-desktop zorin-desktop-themes zorin-icon-themes

Reboot, test that themes are present and working.
If so,

Killall gnome-software

rm -rf ~/.cache/gnome-software

Launch Software and test.

Shoot :roll_eyes:

Sorry... it's late... typo...

sudo apt install --reinstall zorin-os-desktop zorin-desktop-themes zorin-icon-themes

Ah didn't notice that either haha

Yeah, it seems like it didn't matter, same ol' errors, it's no biggie anyways, just wanted to know if there was a quick fix, thanks for the help though, very much appreciated. :sleeping:

That is odd. Clearing Gnome software cache after removing Breeze/Oxygen should work.
Without the theme installed to reference, how can it reference it?
Is it just the icons or the system theme, as well?

@Briccio you should:

sudo apt install gnome-tweaks

@Aravisian correct me if the package name is different.
And then open it and reset its settings to the default.

1 Like

Hi! Sorry went on a trip these days, I have tried that already, still doesn't work... If it's of any use, it also happens in this menu...

you'll have to click on the hamburger menu up there and then "Reset to The Defaults"

If it does not work, you'll have to do another thing. Tell me if it doesn't.

If in doubt, gnome tweaks should be found advertised in the Software Store.

Clearly, some KDE Specific styling remains.

In terminal can you run:

dpkg -l | grep -E "plasma|oxygen|breeze"

Do not remove anything just yet; Just please report back the output.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.