GNOME Software sets 100% for a software instead of 101%

I ran gnome-software on terminal and got all this :point_down: after installing OpenArena.

10:44:14:944 Gs  cannot set 101% for system/flatpak/flathub/io.github.ec_.Quake3e.OpenArena/stable, setting instead: 100%
10:44:15:444 Gs  cannot set 101% for system/flatpak/flathub/io.github.ec_.Quake3e.OpenArena/stable, setting instead: 100%
10:44:15:945 Gs  cannot set 101% for system/flatpak/flathub/io.github.ec_.Quake3e.OpenArena/stable, setting instead: 100%
10:44:16:601 Gs  cannot set 101% for system/flatpak/flathub/io.github.ec_.Quake3e.OpenArena/stable, setting instead: 100%
10:44:19:531 Gs  cannot set 101% for system/flatpak/flathub/io.github.ec_.Quake3e.OpenArena/stable, setting instead: 100%

Should I worry about it or is it β€œnormal”? The game was installed though. I searched info about this but results weren't showing it.

You can see at the end it says that it's using 100% value instead, so this is probably just a warning. The progress indicator is usually calculated based on factors like download speed vs time, which can vary from one moment to the next so are only estimates, and weird offsets like this can happen from time to time.

1 Like

So since these are just wrong calculations why must they be shown? Where's the relevance in knowing this 1% exceeding the maximum for a download process calculation?

Probably for debugging or reporting purposes. If the calculation was off by 2500% that would probably mean something else is going on.

2 Likes