GNU GRUB dual boot slow

Hello, so I'm a very new Linux user, I was be able to dual boot my old laptop with windows 7 and zorin os, but everytime I want to boot windows I have to wait for grub animation to finish loading entire menu before I can press down arrow again, how to make the animation faster or entirely remove it, if it's doesn't possible at least is there any possible ways to place windows at second, replacing the zorin advanced?

This is very bothering me since I can't play genshin impact on GeForce now and I have to boot back to windows and I need to hibernate it for faster boot.

Boot time can vary based on whether you are using HDD or SDD and what programs must initialize. Having a lot of Snap Packages can increase boot time, as well.
This time is the time it takes to run Init - the initialization of all services.

The Grub Animation serves the purpose of keeping the screen active during that Init Time. It does not contribute to the init time in way, it merely plays during the init time. If your init time is short, the animation ends early. If your init time is very short - then you may not see any animation at all.
You cannot remove it as far as the time it takes. You can disable there being an animation - but it will not have the effect that you are looking for.

I do not know offhand how to do that... But I do know how to change the Zorin Boot order as listed in grub.
Let's look at grub:

sudo nano /etc/default/grub

You will see:
That value of 0 puts Zorin as the First Boot in the Boot Order. If you change that to a value of 1, then it it puts it in the second boot in the order:
You can put it in the third order if you have three O.S.'s installed too:

Once you make your change, tap ctrl+o to overwrite, then the enter key to save current configuration. Then tap ctrl+x to exit the editor.
Now, you must run:

sudo update-grub

for the changes to take effect. You can then reboot and test how the system offers the boot order.

This is actually what I mean if I'm correct, Ubuntu has different grub style.

Doing this also just place the selection box to the second menu (zorin advanced).

That is not a Grub Animation - that looks like a Looping menu. In the case of Dual Boot with Windows, this loop is often caused by Windows being in Hibernation rather than having been properly shut down.

You can use grub customizer to change the order of items offered by grub.

Huh, that's weird, I think I was shutdown it properly and I don't think it was hibernated or giving "not shutdown properly - start windows normally" error prompt, and windows 7 doesn't have fastboot hibernate thing that windows 10 has does it?

Ah! that is helping me put windows at second order at least, thank you very much for the answer.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.