Google chrome scale issue

Hello, I just installed Zorin 16 Core on my girlfriend's laptop. Everything works like a charm but I am having issues with chrome.

Basically, font and UI are way too smaller compared to the rest, I know this is a common issue on a lot of distros, I have been able to solve it on my Fedora 34 with this:

Exec=/usr/bin/google-chrome-stable --force-device-scale-factor=1.2 %U

I tried it also on her laptop but it doesn't work. I only discovered that if you apply the same flag also to these other 2 Exec:

Exec=/usr/bin/google-chrome-stable
Exec=/usr/bin/google-chrome-stable --incognito

You get chrome UI zooming a lot, like a scale of 1.5 or more is applied. I tried also to reduce the scale from 1.2 to 0.80 on all of them, but nothing is working.

How do I resolve this issue?

On your computer, open Chrome.
At the top right, click More. Settings.
Under "Appearance," make the changes you want: Change everything: Next to "Page zoom," click the Down arrow . Then select the zoom option you want. Change font size: Next to "Font size," click the Down arrow .