Got a black screen instead of login GUI

I got a black screen instead of login, It was really stressful, being locked out of my own hard drive/OS is just a horrible experience.

I ended up solving it. So what happened was, I was downloading a file that had 20 minutes left until finished in my internet browser. So I left the single tab internet browser open & told my terminal "sudo shutdown +50".

Many hours later I rebooted & got a black screen, I couldnt do jack. So I hit Ctrl F5, tried to login that way, it let me log in via terminal, but couldnt launch the GUI login screen. Then i did sudo apt install --reinstall zorin-os-desktop.
Bingo, This is all that i needed to do, it fixed it, thank goodness.
But what caused this serious glitch to occur in the 1st place? i dont know.
instead of only doing sudo shutdown should i have maybe ran a kill all process? to help Zorin shutdown?

1 Like

It seems unlikely to me that your delay command in terminal had any effect.
My first suspect would be a failure in GDM.

Reinstalling the Zorin OS Desktop would have reinstalled GDM with it.

1 Like

Another option (provided GDM is not corrupted) with terminal login, is that once logged in you can start the desktop with:


If it does not respond, then do as you have done.

1 Like

@swarfendor437 , @Aravisian , Thanks! I will take note of it in case it happens again. :slight_smile:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.