Got an Error Message

I was attending online class when i saw that there was a red exclamation mark on my taskbar. I clicked it and got this.

Screenshot from 2021-09-06 11-23-15

This is what I got when i tried apt-get

jeslin@jeslin-Satellite-L510:~$ apt-get
apt 2.0.6 (amd64)
Usage: apt-get [options] command
       apt-get [options] install|remove pkg1 [pkg2 ...]
       apt-get [options] source pkg1 [pkg2 ...]

apt-get is a command line interface for retrieval of packages
and information about them from authenticated sources and
for installation, upgrade and removal of packages together
with their dependencies.

Most used commands:
  update - Retrieve new lists of packages
  upgrade - Perform an upgrade
  install - Install new packages (pkg is libc6 not libc6.deb)
  reinstall - Reinstall packages (pkg is libc6 not libc6.deb)
  remove - Remove packages
  purge - Remove packages and config files
  autoremove - Remove automatically all unused packages
  dist-upgrade - Distribution upgrade, see apt-get(8)
  dselect-upgrade - Follow dselect selections
  build-dep - Configure build-dependencies for source packages
  satisfy - Satisfy dependency strings
  clean - Erase downloaded archive files
  autoclean - Erase old downloaded archive files
  check - Verify that there are no broken dependencies
  source - Download source archives
  download - Download the binary package into the current directory
  changelog - Download and display the changelog for the given package

See apt-get(8) for more information about the available commands.
Configuration options and syntax is detailed in apt.conf(5).
Information about how to configure sources can be found in sources.list(5).
Package and version choices can be expressed via apt_preferences(5).
Security details are available in apt-secure(8).
                                        This APT has Super Cow Powers.

Thanks in advance.

1 Like

In terminal, can you please run

sudo apt update

and relay any 404 errors or other errors here?
Also run:

sudo apt --fix-broken install

and paste the output here?

2 Likes

I also had this error when I started using Zorin Os, sudo apt --fix-broken installfixes it.

jeslin@jeslin-Satellite-L510:~$ sudo apt update
[sudo] password for jeslin:       
Hit:1 http://ppa.launchpad.net/apandada1/blanket/ubuntu focal InRelease
Get:2 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]      
Hit:3 http://in.archive.ubuntu.com/ubuntu focal InRelease                      
Hit:4 http://ppa.launchpad.net/linuxuprising/apps/ubuntu focal InRelease       
Get:5 http://in.archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]     
Hit:6 http://ppa.launchpad.net/lucioc/sayonara/ubuntu focal InRelease          
Get:7 http://in.archive.ubuntu.com/ubuntu focal-backports InRelease [101 kB]   
Hit:8 https://packages.zorinos.com/stable focal InRelease                      
Hit:9 http://ppa.launchpad.net/zorinos/apps/ubuntu focal InRelease             
Hit:10 https://packages.zorinos.com/patches focal InRelease                    
Get:11 http://in.archive.ubuntu.com/ubuntu focal-updates/main amd64 DEP-11 Metadata [283 kB]
Hit:12 http://ppa.launchpad.net/zorinos/drivers/ubuntu focal InRelease         
Hit:13 https://packages.zorinos.com/apps focal InRelease                       
Hit:14 http://ppa.launchpad.net/zorinos/patches/ubuntu focal InRelease         
Hit:15 https://packages.zorinos.com/drivers focal InRelease                    
Get:16 http://in.archive.ubuntu.com/ubuntu focal-updates/universe amd64 DEP-11 Metadata [351 kB]
Get:17 http://in.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 DEP-11 Metadata [944 B]
Hit:18 http://ppa.launchpad.net/zorinos/stable/ubuntu focal InRelease          
Get:19 http://in.archive.ubuntu.com/ubuntu focal-backports/universe amd64 DEP-11 Metadata [10.3 kB]
Get:20 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [27.6 kB]
Get:21 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [61.1 kB]
Get:22 http://security.ubuntu.com/ubuntu focal-security/multiverse amd64 DEP-11 Metadata [2,468 B]
Fetched 1,064 kB in 5s (198 kB/s) 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
1 package can be upgraded. Run 'apt list --upgradable' to see it.

jeslin@jeslin-Satellite-L510:~$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libaudclient2 libid3tag0 libimlib2 liblua5.1-0 libxmmsclient6 libxnvctrl0
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
2 Likes

Do you still have the error? If you still have it, restarting should fix it. You can run sudo apt autoremove to remove unused packages, BTW.

Probably just a dependency issue

Think that fixed it. The error message is gone. Thank you for helping. :grinning:

2 Likes

Can you also go ahead and run sudo apt full-upgrade

Glad to know everything is working.

2 Likes

yes I've done it

2 Likes

Out of my curiosity, may I ask what does Super Cow Powers mean?

1 Like

I think it's just to warn the user to not destroy others computers

1 Like

I don't get how the words "Super Cow Powers" can be used as a warning. :thinking:

1 Like

I'm not too sure, you can ask @Aravisian.debian - What's the story behind Super Cow Powers? - Unix & Linux Stack Exchange, I found this link. :rofl:

2 Likes

You already answered it. :slight_smile:
Of which is also an homage to Gary Larson.

2 Likes

So, it's an easter egg. Did not know the man loved cows. :cow:

4 Likes

Haha, I also didn't know that he loved cows.

1 Like

I tried getting the Easter egg and typed it wrong and accidentally found out that there is also one where he says "This aptitude does not have Super Cow Powers"

2 Likes

yes there is many Easter eggs.

1 Like