Graphics problem


This is my first time using Zorin after migrating from Windows today.

Some parts of my graphics show like this. Would you have any idea what may cause it?


This is my graphic data.

       description: VGA compatible controller
       product: Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:04:00.0
       version: d0
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix vga_controller bus_master cap_list
       configuration: driver=amdgpu latency=0
       resources: irq:44 memory:e0000000-efffffff memory:f0000000-f01fffff ioport:d000(size=256) memory:fe600000-fe67ffff

You may want to run a live boot with safe graphics and see what happens.

Sorry, did you mean to re-install the installation with safe graphics? will it overwrite all my files?

No, I meant run a live boot as in 'Try Zorin OS'. Normally a live boot from a USB/CD-ROM doesn't modify your computer.

Once you boot into the USB, don't click 'Install Zorin OS', instead, click 'Try Zorin OS'.

Ok, I just tried in safe mode, and it works! Thanks for your pointer.

What do I do now? Hopefully there is some way I can still preserve my data.

I believe Zorin does have a backup program, which you can use to back up data to a hard drive or Google Drive (if you have a Google Account). By default, it only backs up all folders in your home directory.

Or you could use method 2, where you can copy your important data to USB/cloud drive.

Thanks so much! I will look into that. So, I have no choice but to reinstall using the safe mode.

Hi Turtle11, I have reinstalled with safe mode on now, but the problems reappears. It was fine during trial, but not after actual installation. Would you know where else I can look at to investigate?

Maybe try booting into Wayland?
(In the login screen, click your username then click the cog icon (located bottom right) then click Zorin Desktop on Wayland).

Or looking at the proprietary AMD drivers:

It names in gpu "artefacts" - you can used a google to research what that means.
I have that experience with my gpu amd radeon r9 390 the processor gpu is working ok but one from memory gpu propably is damaged broken - ( i mean ram in gpu) - it propably could be also wrong drivers or temperature. I tried downgrade speed gpu and Mhz maybe will be life longer.
It is hardware issue not a operating system.
The best idea using live usb and backup all important files.

Thanks a lot. I am trying it right away.

Thanks for your input, @Bourne. It was working on live USB, but not after I performed the installation. the graphic card was working fine when it was in Windows thought. (I migrated from Windows to Zorin today).

This step works! Thanks so much @Turtle11

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.