Grub failed to install in a Dual Boot Laptop

Hello everyone, my first post here and I need your help!

I was trying to install ZorinOS via dual boot on an old Samsung laptop, so I partitioned it and everything was going great until I finally got an error: 'grub-install /dev/sda failed This is a fatal error'. Afterwards I got the option to restart the operating system, but the only thing that appears after restarting is the Grub screen, so I can write a command. It won't let me boot either Windows or Zorin. The only way I have now is to boot to my USB so I could try to reinstall it.
Here I leave my pastebin with the boot-info information, I really don't know much about this: Ubuntu Pastebin

Thank you very much in advance!

That sounds like what happened to me! Does your old Samsung laptop happen to be a model with a 64bit CPU but a 32bit (U)EFI?

I had to use LMDE 32bit to install 32bit grub before installing Zorin, which just added its own config instead of trying (and failing) to reinstall 64bit grub.

Sorry for the slow response, but how do I check if the (U)EFI is 32-bit? It's really the first time I've read it. The Samsung laptop that I own has an Intel x64, W10 also 64-bit, I don't know if it's of any use but its code is "300V4A-A0GMX". It's really the first time I've seen this error, the first time I installed Linux it was the "linux lite" distro and I did the same procedure as this time but I didn't have any problems that time (but now there's only the "grub"). I wanted to venture to other distros so I could give it some new breathing space, maybe it's a similar case to yours but maybe I did something wrong during the installation.
PS: Yes, I'm a newbie to all this...

It does look like it's fully 64bit, so I'm not sure what your grub issue was. Unfortunately I can't read your pastebin as it's behind a login screen and I don't have an Ubuntu account.

I would suggest installing another linux distro to see if that works, and if so install Zorin over it again. Even if you don't have the same 32bit (U)EFI problem I had, the same general process may still work and let you install a working grub bootloader which Zorin can make use of.

Welcome to Forum!

Did you check if your disk is dynamic or basic? Try running boot-repair application which is pre-installed in the Live Sorin to check for problems?
Also the bootloader location varies as per partition structure/table. If it is GPT then bootloader location is the EFI partition and if it is MBR then it is the /dev/sda.

Hello, a small update on my problem. At first I decided to follow a small guide to try to repair Grub with the terminal, I tried to start the kernel without any success, and exit didn't give me a solution either, so I gave up. Then I followed the recommendation of using the "boot-repair" that comes with ZorinOS, but there was a small error during the repair, it was "nvram is locked (zorin not found in efibootmgr)". "No changes" were made and the computer restarted. Surprisingly, my error had been solved by creating another error (or so I think) and the grub started without any problem, I could now start either Windows or Zorin, I opened each system individually, tried to install programs, turn it off and everything was normal... I don't know what could have happened or what the initial problem was, but it's fixed (I think). I would have to do more tests such as updating the systems to see that everything continues to work.

3 Likes

Ok. It seems your error has been solved if yes then please mark your post(or any other) as solution.
:slightly_smiling_face: