Grub is not showing up to choose kernel

Hello.

I've recently downloaded a Xandmod (5.15) kernel to try to see improvements in certain games.

When I installed it, I was told by others that I could simply pick the kernel the moment I install it on the GRUB menu, in case I ever wanted to roll back.

The problem is I realized that on my laptop with an encrypted disk, I never see the GRUB menu. I haven't since I installed Zorin.

First, I get the encrypted password login screen, and after that is succesfully entered I get sent immediately to the Zorin login screen for the OS.

Obviously, GRUB is not reachable for what ever reason.

I tried changing the boot order to show "grub" first before "ubuntu", and all I get is a Dell "pre-boot system performance check", performing a system scan. I don't get the actual grub menu displayed.

I know for a fact that it "should" work, because I also have Zorin on my main Desktop, also with an encrypted disk and the Grub does indeed show up.

Is there any way to repair this situation so that I can freely choose the kernel that I want to use?

Thanks!

1 Like

Don't know if this thread on Ask Ubuntu helps?:

I'm reading this but holy ■■■■ wow, encryption is such a pain in the butt that I may hold off on it... I'm seeing now that encryption may be issue.
I guess my next question would be, how do I roll back to the default kernel that Zorin uses?
Thanks

Take a look here:

I realize that this was a simple web search now. Thank you and sorry if I wasted your time! Thanks!

Don't be sorry - we all start from somewhere. There are other methods of removal that might be a bit more simple - I am pretty sure Aravisian has posted more succinct answers than mine.

1 Like

Aravisian also encrypted his disk and later regretted it and came to you asking how to fix it. :stuck_out_tongue:

2 Likes

ACTUALLY! Hold on for anyone reading this in the future... I SOLVED IT.

Turns out you need to edit your GRUB config file and check to make sure that
"GRUB_TIMEOUT_STYLE" is set to "menu", and your "GRUB_TIMEOUT" is set to what ever number you want greater than 0.

After making a back up of your Grub config file, of course.
This displayed the GRUB menu for me.

Thank you everyone!

1 Like

an easier solution would just be to hold the shift key when booting

Grub Timout should never be set to Zero. We have covered this on the forum many times.
The default that comes with install is 10, not 0.

It is also one of many reasons I recommend against the use of Grub Customizer.

2 Likes

And the reason? because it is a journaling system! When I was an IT Contractor, the Director of Housing Services was known for his impertinent practice of reducing boot sequence on NT4 systems to 0 seconds - also a journaling system. Journaling systems should not have boot parameter set to less than 5 seconds.
On encryption generally, when I purchased Open SuSE 9.3 Professional, the installation guide clearly warned that encrypting your disk can lead to loss of data - that is why I NEVER encrypt any drive. I was asked at work by my line manaer many years ago that she wanted her PA to have her Data encrypted. I built the machine, at the time it was Windows XP I believe, so the OS and Apps on Primary and a logically encrypted Data partition. 3 days later the machine fell over - reinstalling the OS meant that the PC had a new HDD id and so the encrypted partition was lost forever - fortunately the PA had made a backup of all her data before the new build anyway so only one day or so's work was lost.