GRUB isn't showing on boot

Back again with another problem I've no idea how to solve it.

I recently reinstalled my whole system moving Zorin from my "secondary" drive to the main drive and windows the other way around.

Since windows is somewhat stupid and puts their boot-manager on the main drive even though I install it on the secondary, I had to physically remove the main drive to properly install it. Windows then installed fine, no issues here.

Then I put the main drive back in, removed the secondary drive to avoid any hiccups and installed Zorin on it. Works fine too, no issues here.

Plugged my secondary drive back in, started Zorin.

I tried out Fedora before and there I had the problem that grub did show up but the Windows entry was missing. So I found this post which solved my problem: dual boot - GRUB does not detect Windows - Ask Ubuntu

So I tried it the commands again:

sudo os-prober

which found the boot manager:
image

And then added it to the boot menu via

sudo update-grub

which also worked like the last time:
image

But grub still doesn't show up. Like... Not the "Windows"-entry is missing but grub as a whole.
In the boot menu there's only "ubuntu", "Windows Boot Manager" and the drive windows is on available.

Also: I don't know if it's important but I encrypted my Zorin installation with LUKS... but since Grub has it's own boot partition, I kind of assumed it wouldn't affect that?

Any ideas?
Thank you in advance! :slight_smile:

Firstly, try booting into your BIOS / UEFi control panel and check the boot order / sequence (exact terminology may differ) to make sure Zorin / ubuntu appears in the list and, if so, ensure it's at the top.

If that doesn't help, or it's not in the list, use something like Super Grub2 Disk (or rescatux made by the same people) to scan for and boot into Zorin. Assuming you get into Zorin, try sudo grub-install followed by sudo update-grub.

You could also use efibootmgr to show and modify the entries in your computer's (U)EFI register, but that is more advanced and gives you much more chance to break your setup further.

If you SG2D can't detect your Zorin installation, your best bet is to reinstall, as far as I am aware. I don't know how else you would check that it is still there and get into it, especially being LUKS encrypted.

A note: the bootloader should always be installed in the EFI partition of the main drive, regardless of whether the O.S. is installed on the secondary drive or third drive...

Windows and Ubuntu both show up and boot perfectly fine when selected.
But Grub somewhat "isn't there". Before I start installing different tools, I wonder if there isn't any way to configure grub itself?

Why though?
When I reinstall the OS on the main drive, it wipes the drive (as long as I'm not creating all the partitions myself) which would kill the windows installation.

Installing the O.S. in its partition is not the same as installing the bootloader in the EFI partition.
Use your partition manager to install the O.S. of choice to the partition and drive of your choice, leaving the main drive containing your EFI partition (Which is independent of either O.S.) connected.
If your bootloader is in a separate EFI partition from main, how is os-prober going to see it?

In a terminal window:

sudo gedit /etc/default/grub

Add the following line at the end of the file:

GRUB_DISABLE_OS_PROBER=false

  • Save & exit and then sudo update-grub
  • Reboot and check
3 Likes

That worked, thank you very much mate.

I get an error at startup where it states it hasn't found a server (idk what server) and afterwards it shows up the basic grub menu without the Zorin theme but it works perfectly fine.

Thanks a lot! :slight_smile:

2 Likes

I did something similar, but I didn't add the prober. First, I used the sudo command:

sudo nano /etc/default/grub

You'll see the following menu:

I then changed the menu style from "hidden" to "MENU" (all caps)
Then changed the GRUB_TIMEOUT from "0" to "10"

It should look like this:

Hit Cntrl+O, Enter, Cntrl+X.

I then used the following sudo command to update the GRUB menu:

sudo update-grub

Restart the computer and you should see the Grub menu without any further issues.

I know this topic has already been resolved. I was simply offering an alternative solution.

2 Likes

Hello old friend. Hope all is well in your neck of the woods. I've gained much experience since my first time on the forum and I'm looking forward to helping as many people as possible. At least with Zorin 16.3. I still think Z17 sucks, and it does.

1 Like