Grub not recognising Windows

I had only zorin installed in my laptop on a 512GB NVMe SSD. Recently I bought an 2TB external HDD thanks to that now I have a lot of space in my laptop so I created a new partition where I install windows. Now both system load ok, but Zorin's Grub do not reconize Windows
sudo os-prober recognize the new partition with Windows

I can, when starting my laptop, press F12 and enter the boot menu, then choose which system I want to start, but is not the ideal
Note: To create the new partition I only reduce my home partition, the / partition is I din't touched.

This might help:

1 Like

Thanks @swarfendor437 the first option given there says to run sudo update-grub a thing I already did, but with one difference, now I read and actually says this

Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.
Check GRUB_DISABLE_OS_PROBER documentation entry.

The thing have to do was add the line


in /etc/default/grub


Another bit of background info, to help understand what's going on (and is useful to me) in case anyone is interested (ICAII, is that a thing?). Which is why negating the os_prober disable is needed.:

OMG Ubuntu 22.04 & GRUB issue

"The cause? The OS_prober feature is disabled by default in GRUB 2.06, which is the version included in Ubuntu 22.04. This is an upstream change designed to counter potential security issues with the OS-detecting feature (it mounts partitions to check for other OSes, this could be taken advantage of, etc).
"So, for the moment, Ubuntu 22.04 (or more accurately GRUB in Ubuntu 22.04) does not detect any other operating system during or after install. Ubuntu's Julian Andres Klode acknowledges that this is "...a bit controversial and the outcome is not necessarily in the best interest of our users".


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.