Grub Parameters and dual booting

Hello members.

I've been dual booting (elementaryOS, Fedora 34) using Zorin OS 16 Pro's grub as the main boot manager. I know there are many topics surrounding this, however searching the forums I couldn't find anything that fits my situation.

After reinstalling Zorin's grub to make it the main boot manager, it successfully detected the other Linux operating systems. However with Fedora, instead of the usual graphics boot up, it is all ascii text console. I would like to get Fedora to once again use the splash graphics. All other OS's use the it's splash boot up graphics.

During boot, if I manually add "rhgb quiet" to Fedora's kernel parameter line, it boots with the splash graphics. So how do I pass parameters to my other kernels at boot up using Zorin's grub? I know with all Linux OS's it doesn't matter which grub boot manager I use, however I would like to keep using Zorin's since it is my main daily use OS. Thanks again!

sudo nano /etc/default/grub

Find the line with quiet splash and add "rhgb quiet" to it as:
"quiet splash rhgb quiet"

Unfortunately, that didn't seem to work. After I made the change, I ran

sudo update-grub

Should I not run update-grub?

Yes, that is necessary. Hmmm...

I am sorry to take so long, I have been trying researching this since Fedora handles the argument differently.

Fedora's /etc/default/grub...
fedoraGrub

Zorin's /etc/default/grub
ZorinGrub

However, during the boot cycle, when going into the boot menu and looking at the boot menu options, only the kernel is there. I don't see any options on the kernel boot lines.

So long? LOL...it wasn't even 10 minutes! Thanks for replying.

I'm a bit at a loss, on this one. Both distros use Plymouth.

You may consider trying different configurations...

GRUB_CMDLINE_LINUX_DEFAULT="rhgb quiet splash"
GRUB_CMDLINE_LINUX=""

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="rhgb quiet"

...

Weird...it doesn't seem to pass the params to fedora's bootloader kernel line.