Grub repair

After installing zorinOS 16 on the same sda disk (sda3) as another Linux distribution already installed on another partition (sda4), the hoped-for grub menu at boot time is not displayed.
Please let me know what Terminal commands to enter to restore it.
Thanks.

Does the other Linux Distro use SystemD boot?

If not; Can you please check your grub timeout:

sudo nano /etc/default/grub

Ensure it is set to 10

Test that you can pull up the Grub Menu at boot by tapping the esc or tab key (EFI Boot) or the Left Shift key (MBR Legacy - you can just hold this key down instead of stabbing at it) from the motherboard splash screen.
If that is working, then we likely do not have to repair grub.

Great, thanks for reply, yes grub timeout is set to 10 but it boots with the other menu grub I installed first, However, I would like to boot the PC to the GRUB menu of zorinOS.. All installed on UEFI Boot not legacy one.

What about
GRUB_TIMEOUT_STYLE=menu instead of GRUB_TIMEOUT_STYLE=hidden?

Hidden, Sir

Try setting that to menu.
Once done, tap ctrl+x, then the y key, then enter
Now, run

sudo update-grub

Reboot and test.

here is the menu grub...

If you change this file, run grub-mkconfig -o /boot/grub/grub.cfg

afterwards to update /boot/grub/grub.cfg.

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR="Kali $(cat "/etc/Kali-version"|cut -d" " -f2)"
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""

Uncomment to disable graphical terminal (grub-pc only)

#GRUB_TERMINAL=console

The resolution used on graphical terminal

note that you can use only modes which your graphic card supports via VBE

you can see them in real GRUB with the command `vbeinfo'

#GRUB_GFXMODE=640x480
#GRUB_GFXMODE=1024x768x32

Font used on the graphical terminal:

GRUB_FONT=/usr/share/grub/dejavusansmono.pf2

Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

#GRUB_DISABLE_LINUX_UUID=true

Uncomment to disable generation of recovery mode menu entries

#GRUB_DISABLE_RECOVERY="true"

Enable os-prober to find other distros

GRUB_DISABLE_OS_PROBER="false"

Theme & Background

GRUB_THEME=/boot/grub/themes/Kali/theme.txt

1 Like

I tried that before, but menu grub still boot from other distro, not zorinOS.

You can add the line if it is not present.
I see your other distro is Kali (Great OS). I do not think that should interfere with an Ubuntu based distro, but I am not certain on that.
You might try

sudo grub-install /dev/sda3

Then boot into Kali and run

sudo grub-install /dev/sda4

Reboot and see if you have access to the menu. Ensure that your Grub Files include
GRUB_TIMEOUT_STYLE=menu and if you add that line, to run

sudo update-grub

after.
That really Should Work... The usual other cause of osprober failing to recognize a distro is if one is installed MBR and the other EFI.

Typing sudo update-grub shows kali found on dev/sda1, "the zorin distro is on sda4" but not shown after update done...

Ah ok, the OP said sda4. Please adjust the commands as needed.

thanks
receive my dearest greetings