GRUB's disappeared

I'm not sure about any of the following.

I have an HP Pavilion laptop that dual boots Windows 10 and Zorin OS Lite 12 (yes, I know that's an old version, there are reasons why I don't upgrade it). Or, rather, it did. After the battery completely ran down and I plugged it in and switched it back on, the GRUB bootloader had apparently disappeared and it went straight into loading Windows and didn't admit to having Zorin installed, although by the look of it the contents of the hard disk are as they were.

I found these instructions for installing GRUB and tried to reinstall it (working from a Live USB stick with Zorin - I can't be doing with Windows 10 and only have it on there in case I need it for something), but when I got to "sudo mount /dev/sda1 /boot/efi", apparently the Live USB stick hadn't got a "/boot/efi", so I tried with the path of the hard disk's "/boot/efi" instead, while still working from the stick, but it said "grub-install: error: /boot/efi doesn't look like an EFI partition".

Is it possible to get GRUB back, short of re-installing Zorin from scratch?

First, are you certain Zorin 12 and Windows are using EFI boot? Were they using MBR boot?

You can check on your BIOS Settings if MBR is selected (Legacy).

Apparently, it's fixed! It seems like, I looked in the BIOS settings to see whether it was EFI or not (it possibly was, though I'm not sure!), and noticed that Secure Boot was enabled, and something else I'd seen in the forum while checking whether there was already an answer to this question had reminded me that it ought to be off, so I turned it off, and that fixed it - as simple as that - apparently I'd forgotten all about Secure Boot. Possibly, the BIOS had lost its settings because the battery was so flat, and had defaulted to that. Thanks for your help!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.