Gta V crashes when loading parts of maps or cutscenes

I have 8 gb of memory (RAM) enough of disk space for the game and etc. , gpu GTX 1650 and cpu i5-9300H 2.4GHz
Zorin OS 17.1 Core 54bit
As I typed in tittle of this topic gta v just crashes or freezes for long duration of time when loading parts of maps or cutscenes (I alr tried benchmark from gta and it also does the same) I tried starting commands for gta without them tried lowest possible settings and etc. but it just doesnt help with the problem. Could someone please help me with this?

Hi, and welcome!

My guess is that you're pushing the RAM usage a little too far. When the Linux kernel is running low on memory it would start shutting down processes in order to keep running. For this game in particular, it may be that certain parts require loading additional data into memory, even if temporarily, that result in this behavior.

One thing that you can try to do is to enable ZRAM which essentially makes more efficient use of RAM by compressing it. This comes at the cost of CPU cycles but I don't think this should be a problem with the one you have.

I am going to try that and if theres any other problem then I am making another reply

Story mode is all good but online first mission (race) is just making my game freeze in one spot so idk what to do now (enabled ZRAM already) I didnt have anything in background other than steam, and replaced thermal paste + deep cleaned my pc right before enabling ZRAM so I dont really know what the problem is.....

If this made a difference, I guess the issue is the same and your system continues to run out of memory, it's just taking longer to get to that point.
You can take a look at the logs and see if there's any mention of the Out Of Memory Killer process being invoked, this is what starts shutting down processes when there's not enough memory. You can run this in terminal to look for traces of it:

grep -i oom /var/log/{kern.log,syslog}

In addition, as per the article linked above, try to use more of your physical RAM instead of the suggested half and/or change the compression algorithm to something more aggressive, by editing the /usr/bin/init-zram-swapping file.

Other than that, I'm not sure what else it could be. I suppose it's possible this is an issue with the graphics card drivers. I'm reluctant to give any advice on this as I know nothing about drivers and graphics card, so better wait for recommendations on what could be done at this point.

1 Like

I found out what the problem of online crashes was, I had corrupted files somehow...
Anyways thank you for the help

1 Like

Just curious, how did you find about that? It might help others who run into similar issues in the future.