H.265 HVEC Codec Installation on Zorin OS 16.2

Good evening all,

I've been slowly trying to move away from the Microsoft world and I have a question that I've spent most of the afternoon trying to resolve. I figured I'd post it here and see if I can get any help.

I have a Dell G15 Ryzen 7 5800H, 16GB RAM, 512SSD, RTX3060Ti setup. I've been using DaVinci Resolve 18 on Windows 11 for a while now and I love the program but didn't realize it was available on Linux.

I just installed Zorin OS 16.2 64-bit core edition this morning. I've been using Zorin OS for a while now for my Development job (.Net Core C#/Blazor) and I love it. I managed to get DaVinci Resolve 18 installed on my new installation without issue today. It should be noted that I installed the nVidia version of the OS as well.

I shoot all my footage from my DJI Mini 3 Pro in D-Cinelike H.265. I have tried and tried to get the codecs installed and without them I can't import my footage into DaVinci.

I've followed every suggestion from here:

and here:

ultimately I end up getting this error:
Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I would greatly appreciate any help or insight anyone could provide me with this. I'd love for this to be my main driver! Good day all.

Have you tried : How to configure H.265/HEVC in Linux? - Tutorial.

You have to add a repository (use sudo) and it shouldn't give you any hassle.

I'm not sure what setting is preventing you from using an added repo.

Sounds like one of the repos you attempted to add needed a key maybe?!

I will try that link and give it a shot. I appreciate your response. I'll have feedback for you shortly probably.

So those were the same steps I've tried this afternoon but maybe i can just post what I'm seeing and that will help. You mentioned the repo that's failing.

Err:15 Index of /mc3man/trusty-media/ubuntu focal Release
** 404 Not Found [IP: 80]**

As to the solution this is what I'm getting after adding the repo and updating.

E: Unable to locate package vlc-plugin-libde265.

I took a look at the repository:

It is noticeable that the instructions recommending gstreamer and vlc-plugins lack a Focal installation candidate - likely the cause of the error.

Interestingingly, it does include not only Focal and even Jammy packages for libde-265, though none specify gstreamer or VLC. Here is that package in .deb format:

Trusty is Trusty Tahr and that is going back a ways: Ubuntu 14.04.

Remove any repos for Trusty. You can do this from Software & Updates in the other software tab and clicking on mc3man repo to highlight it, then clicking the remove button on the bottom toolbar.

As an aside, here is the full install for gstreamer without any need to add a repository:

sudo apt-get install libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libgstreamer-plugins-bad1.0-dev gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly gstreamer1.0-libav gstreamer1.0-tools gstreamer1.0-x gstreamer1.0-alsa gstreamer1.0-gl gstreamer1.0-gtk3 gstreamer1.0-qt5 gstreamer1.0-pulseaudio

I want to say thank you for helping me get rid of the error. It appears to have installed correctly. I can play the video from my drive It just won't import into Resolve 18 like it normally would on this computer when I had win 11 on it. Maybe i just need to get on their forums and see if they have any suggestions. But I can see and play it now from the drive so I greatly appreciate your help.

1 Like

Just remember to refer to Zorin OS 16 as the equivalent of Ubuntu 20.04 Focal Fossa.

That's fantastic. I am going to mark this thread as the solution to getting it the codec installed since I am able to see my video now. Once again I greatly appreciate your help. Have a pleasant evening.

1 Like

For anyone else that is curious, I just found my answer. H.265 D-log video is not supported in the Free Version of Resolve 18 on Linux. It works in windows just not on Linux in the free version. Hope that helps someone.

Often times, that is a surface answer. We may need to look deeper:

This is not an answer or solution for that issue at this time - just a recommendation to not yet throw in the towel for it.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.