Hangul 한글 keyboard layout not well


When using the Hangul Keyboard it works but the layout shows something else and in games and other applications like steam, the keys come out as shown in the layout. anyway, I can change the layout?


I've read this ubuntu forum. but I don't know How I can use his keymap to input into Ibus. thanks in advanced-Derek

Have you installed additional packages under Manage Installed Languages ?
Have you navigated to Install / Remove Languages and clicked the checkbox for Korean and clicked apply?
Ensure that Keyboard input method system is set to ibus while you are there. You may also need to drag the Korean language selection to the Top of the List to apply it system-wide.
Open a terminal and run:

sudo apt install ibus-hangul

sudo apt update && sudo apt full-upgrade

sudo reboot

and test...

Yes, as said the Hangul keyboard works but in certain applications it goes to Inglish, and when I press keyboard layout I see the English one even though it types in 한글

And you did ensure it is installed as System-Wide above?

Steam kind of does its own thing in regards to a lot of system settings, I have noticed.

I am probably one of the least knowledgeable people to help on questions about ibus though, so hopefully other experienced members can provide better input.

I just wanted to say, I saw your thread, and decided to look at my STEAM APP. I couldn't find keyboard options in the APP which is weird. There is in INTERFACE options, but nothing for keyboard layouts is present in it.

The arabic keyboard works, as it also has the keyboard layout but Hangul 한 doesn't

Hey, use what works I say! :+1: :slightly_smiling_face:

What? Hangul alphabet and Arabic Alphabet are no-where similar

힌 and يىىت

1 Like

@FrenchPress may have more experience on using Multiple Languages on Zorin OS.
Though, I apologize for dragging you into the mire...

I only use English and Japanese - so "multiple languages" is a big word :wink:

I am afraid I know nothing about Korean language. I also use US English keyboard, not a language specific keyboard myself.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.