Has anyone installed Zorin OS Pro on HP Envy x360

I just got an HP Envy x360 15z-ee100. I wiped Windows and tried live Ubuntu, Zorin, Manjaro, Fedora on it but the screen rotation and fingerprint sensor don't work. WiFi didn't work at first. I had to USB tether from my phone to get the internet and then install rtw89 driver to get it working.

Also the stylus doesn't feel as smooth as it did on Windows. I know most of these stuff aren't deal breakers but it pains me to see such poor support for convertibles.

I'm considering getting Zorin OS Pro but I'm not sure if it'll be any better. If only the screen rotation worked as good as it does with Windows, I'd be happy.

I hope others chime in with their thoughts and experience too but I don't think Zorin is the better choice for that device. For hybrid devices like yours, I recommend Fedora since it has the latest kernel and also has the best Desktop Environment for touch/hybrid systems. Try to give Fedora some more try. Maybe even fully install it.
I hope others could provide more insight on this matter.

1 Like

Actually did some searches and it seems that it goes well with Kubuntu and KDE neon too. I'd say that give those a try too.

Tried Kubuntu. KDE doesn't even have an on-screen keyboard so in tablet mode, it's kinda useless. The third-party virtual keyboards are horrible.

Here you can find some documentation on how to get maximum hardware compatibility on fedora. I hope this helps. It has a section on how to get the orientation sensor working.

1 Like

That is a machine that does not want Linux on it. Interestingly, even the hardware support for Windows is limited.
I did find this thread that has a lot of action in it...

1 Like

Let us know what OS you settle on. I'd say it can help others too.


Welcome :hugs:

I have HP Envy x360 13-ar0022nn AMD Ryzen 5 3500U ,with 8 /gb RAM.
And guess what ? It is working much better than on Windows. :slight_smile:

Yesterday I just figured that screen orientation working perfect..

No issues at all.

Yes, fingerprint sensor needs some more adjustments, but I never did that.. password is fine for me

No issues with wifi for me


Lucky you man. Mine refuses to work with any distro at all. It has the 5500U so maybe some of the hardware doesn't have open source drivers yet.

Can you outline how you did this? Perhaps this part may be helpful to the O.P.

Sorry, I missed this one.

I updated my system to the latest, same for kernel ( 5.13) .
I also tried Liquorix kernel.

I don't know if kernel is solution or not, but it is working :slight_smile:


Looks like luck won't favor me after all. I tried both 5.13.12 and Liquorix, still doesn't work.

Well, the 5.4 kernel worked, right?