Having issues with weird duplicate icons on desktop, Wine related

The duplicate icons on the left side that are generic document looking icons wont let me click on them whatsoever. But the icons on the right which actually have the correct logo icon will let me right click on them etc. How do i get rid of the duplicate ones?
See screen recording:

The correct logos with a cross on means they are untrusted icons - you have to right-click and execute. Similarly the text style documents need a right-click to give permissions to be executable. How did you install the .exe files? My only other thought is whether they are compatible - does anything run at all?

1 Like

swarfendor437, Thank you. Like i said, I cant right click the text style ones at all, none of the left sided ones do anything whatsoever. And hence the problem that i cant even delete them, which is annoying. The ones on the right side work fine & they do run once i click on them. I installed them via wine/windows .exe or install .exe file.

All I can think is it is because the applications are needing native Windows to run properly. Are there no alternatives? I would try uninstalling WINE and start afresh. Also try running Zorin in live mode and explore the installed Zorin to delete files showing on the Desktop.

1 Like

Good idea, thank you.

@swarfendor437 , I uninstalled wine, but its still in the launch menu,
how can I uninstall it totally?

Did you reboot after uninstall? Sometimes menu changes require at least a log out if not a reboot for them to populate. The same happens on new installs (not showing in the zapp menu).

1 Like

@337harvey , @swarfendor437 , thanks for the help guys. So it turns out anything i put on the desktop duplicates/glitches. Not just wine shortcuts. So wine isnt the cause. Here is a link to someone who had same issue with ubuntu 2 years ago. (LINK)

Two solutions are provided. Perhaps you guys could please take a look at them and help me with them, as they are a bit over my head.

One is disabling the gnome extension that restored desktop icon functionality (something gnome removed). This will help if you have multiple desktop environments installed. You will have to install gnome-tweaks to resolve this (sudo apt install gnome-tweaks).

The other was because the user added Nemo as file manager and desktop manager. If you have Nemo and nautilus, disable nautilus from managing the desktop.

Which applies to your situation?


I have and use Nemo on a copy of Zorin OS 16 Core without this issue.
I would suspect more than one Gnome Desktop Icon shell extension installed.


@Aravisian , @337harvey , thank you, very helpful.

So it appears either:
1.) I do have nautilus & nemo. I want to try to disable desktop for Nemo?
How do i do that?

2.) How do i see if i have more than one Gnome desktop icon shell extension installed?

-I appreciate your help.

You can check which extensions you have installed total with

gnome-extensions list

For seeing the enabled extensions:

gnome-extensions list --enabled

1 Like

Nemo is the Cinnamon file manager, Nautiluus (now GNOME Files) is the default one for Zorin 16.2. Whatever you do don't try to remove Files (Nautilus) or it will take your whole system with it!

1 Like

@Aravisian , thank you. here is what my terminal shows, do i have more than one Gnome desktop icon shell extension installed?

Jessie@system:~$ gnome-extensions list --enabled

How do i "disable nautilus or nemo from managing the desktop"? that wouldnt be the same thing as uninstalling it i dont think?
And would it be same or different as changing what is my default file manager?

This one here. That affects Desktop Icons:

This is an extension for Gnome Shell that adds icons to the desktop. It is a fork of the original, Desktop Icons...

I do not believe you need to disable the file manager from managing the desktop.

1 Like

@Aravisian , thank you very much, how would u recommend i disable it?

You can disable it from the Zorin Settings > shell extensions or from Gnome-Tweak tool > Extensions

I do not use Gnome, so I cannot recall the exact steps to follow on Zorin OS Core.
But on Gnome Tweak tool, navigate to the Extensions tab on the left pane, then select "Ding" and disable it.

1 Like

@Aravisian ,Yep, thats it, thank you very much.

1 Like

If you are happy that Aravisian's post is your "Solution" can you click :ballot_box_with_check: under his post to mark as Solution. Thanks.

1 Like